Showing results for 
Search instead for 
Did you mean: 

AI Suite 3 Version 3.00.10 & 3.00.13 - user test/report thread

Community Admin
Community Admin
Please check the product support page for your board and download Ai Suite 3.00.14 or 3.00.13 (if available).

If you have a Ryzen-based system:

Ai Suite 3.00.13 updated for compatibility with Ryzen power plans (no other changes):

FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin
1,154 REPLIES 1,154

Im using the ROG X299-XE motherboard and since I guess this month or so, my AI suite III doesn't work, I have even tried re-installing the latest version and I get errors when I try to open AI suite III, and it does NOT open. Or install any utilities properly.

Level 7
Under MOBO Drivers and Utilities. Choose your operating system. Scroll down to Utilities. It will show the most recent utility software, which may or may not be AI-Suite. Below this you have the option to show all. This will display all older versions of the available utility software.

Level 7
I would just stay away from that AI Suite. The auto tuning almost broke my CPU (QCode 00) and had reset all settings from UEFI, uninstall AI Suite and things were back to normal.

I'll just overclock my CPU manually and use Speed Fan which is a very good software.

Level 8
I have an Asus Crosshair VI Extreme mobo and I just clean installed my Windows 10 Home 64 bit. I'm going down the drivers list on the Asus product page and got to the 'Utilities' section. Which is very confusing and poorly laid out and explained. I don't want to install all the random crap that I will never use. But I do want the latest AI Suite software. However, I'm not sure which file that is.

It looks like the latest AI Suite might be AI Suite 3 and is listed as version 3.00.13 dated to Jan 16, 2018. It also seems to suggest that it includes 'Dual Intelligent Processors 5 v1.05.13'.

Three spots above the AI Suite file there is a newer Dual Intelligent Processors version listed. I'm not sure if I'm supposed to install that after/on top of AI Suite 3 or what. ???

I'm not sure if I need to installed the 'AMD Raid Configuration Driver' listed in the Utilities section or not.

There's a 'SATA' section which has one RAID driver listed. I'm not sure if I need that or not.

There's two drivers in the 'USB' section. Not sure if I should install both or not.

It also seems like the chipset driver they have listed is from February 24 this year which would make it really out of date. When I was looking for a newer version of the chipset driver on the AMD website it's showing a chipset driver available from Sept 4th 2018.

There are also a bunch of RAID drivers there, but I don't know if I need them.

Asus does an incredibly poor job at laying these drivers out in a clear and understandable. It shouldn't be this confusing.

Edit: When I went to install the chipset driver from the AMD website this happened. I don't know what this means.

Edit 2: When I click the left side it says this and when I click the right side it says this.

Edit 3: When I click custom install on the right side it shows these options. Should I be installing the 'Balanced Power Plan'? I thought Windows had integrated this already a while ago?

Edit: I cannot figure out how to install AI Suite 3. Every file I download ends up being just "EZ Update" or "Dual Intelligent Processors 5". Where is the latest AI Suite 3 file for my motherboard and Windows 10 Home 64 bit? This is such an unbelievable mess. It's like Asus intentionally makes it as confusing as possible.

So installing the Version 1.05.14 package from ASUS website is the full package with all modules? Or what package you guys are using for setup or reinstall?

Thank you 🙂

Level 8
I wonder why there's a newer version of Dual Intelligent Processors 5 from this thread from January (v1.05.19). While there's an older version on the Asus website for my motherboard (Crosshair VI Extreme) from February (v1.05.14). Doesn't make sense to me. Is it safe to install the file from this thread? Are there any issues with it? What's the difference between DIP 5 v1.05.14 and DIP 5 v1.05.19?

Level 7
Since the last W10 update (1809 17763.1) the "echec de l'execution du serveur progid aahm.acpihmdata2" is back.....
I'm fed up. with this asus soft...

Level 7
After Windows 10 update into 1809 version I got an error but everything became OK after re-installing AI Suite 3.

Level 7
Uninstall->Reboot->Use Cleaner->Reboot->Install last version->Profit 😉

Just tested , W10 1809 update

Level 7
I have a more weird problem, which i cannot find any related post on google..
Since win 10 latest update(October 2018) Ai Suite 3 wont have Dip5 mode.. I tried every suggestion on this forum the last 4 days with no success.
I have a M7G board with the latest bios.
the problem is that every time I install DIP5 , it shows that it have been installed and prompt for restart, but after the restart there is no DIP5. and if i run the installer again I can install it again.
I tried running the setup alone but it just won't run.
all filed unblocked, windows pro official, running as admin..
Also i came across that my base clock speed is lower from bios settings and not even Intel Xtu seem able to change it for some weird reason..
I reinstalled all drivers many times no success..
It is very frustratinting...

Finally manage to get Ai suite work.Had to uninstall it using iobit uninstaller and worked only if i shred the remaining files..
Also only the Ai suite v1.01.05 worked with DIP5 v1.02.27.

Now the issue i have is that the bus clock seem to change in asus suite , but Hwinfo and Windows dont seem to "see" it as the cpu frequency remains the same.. Asus suite and intel XTU from the other hand show the bckl change and as a result report different cpu frequency. is this solvable?

i will update if i find something