Showing results for 
Search instead for 
Did you mean: 

V no longer detects rbg ram

Level 7
Everything was sorta working before the most recent update. After the update the RAM is not detected in Armory Crate but oddly now shows up in Aura Create though it is not usable in Aura Create.

I have tried everything I can think of to get Armory Crate to detect the RGB feature of the Viper Steel 64GB RGB modules. The old version worked fine at detecting the RAM and was able to set all the default lighting schemes. And I had finally gotten Aura Create to usually detect the RAM and work. After the update Aura Create detects the RAM every time but it is non-functional since it is not showing up in Armory Crate.


I would settle for downgrading back to the old version but since this is only downloadable through the installer there is no way to get the old version. I checked, it's not even on the CD that comes with the motherboard.

Any help out there from you ASUS gurus would be greatly appreciated. Right now I am stuck on rainbow mode as that is the mode the RAM boots into. All other devices including fans work correctly.

Windows 11
Patriot Viper Steel DDR4 2x32 PC4-28800 3600MHz
ASUS ROG Nvidia 3060 12GB

Item Version
---- -------
Armoury Crate UWP App
ROG Live Service
Aura Service (Lighting Service) 3.05.66
Armoury Crate lite service 5.2.10
Aura Wallpaper Service Not installed
ASUS AURA Extension Card HAL
ASUS AURA Motherboard HAL
KingstonDram 1.1.12
AURA DRAM Component 1.1.18
Patriot Viper DRAM RGB
Patriot Viper M2 SSD RGB
Universal Holtek RGB DRAM

Hoping someone out there has a clue.

Level 7
Same here! After the last update the armor crate dont show my ddr4 tforce xtreem argb in the app, only rainbow mode! Go asus fix this!

ricksky wrote:
Same here! After the last update the armor crate dont show my ddr4 tforce xtreem argb in the app, only rainbow mode! Go asus fix this!

I called them today and they seem to be aware of problems with the current version of Armory Crate.
I recommend you call them too and complain.

These are some really serious issues given I paid extra for all products with the Aura Sync logo. This should mean the companies in question have sent them hardware or tested the hardware on ASUS motherboards and then pay to have the logo on the box. If you can't rely on the logo to know the products will in fact function as advertised, we should probably demand a refund of those products that are so marked and don't function. I have had issues with this since getting the motherboard.

Granted I did not get the certified memory modules they list for the motherboard but that is for overclocking which I generally don't need.

Call them. Hold time wasn't bad.

ricksky wrote:
Same here! After the last update the armor crate dont show my ddr4 tforce xtreem argb in the app, only rainbow mode! Go asus fix this!

Is this the TForce RAM that is recommended on the motherboards ASUS page as supported RAM?
That SUCKS if it is because I was considering upgrading to it as I like the look of their RGB and it's faster RAM than my Viper Steel RAM which also has great a great RGB look.... when it works.

I'm sure I could resell the VIPER Steel RAM so I would be willing to buy the recommended TForce if it would actually work.

Let me know if you find a solution please. Right now my solution is to restore a backup of Windows to a working version. I cannot believe I am actually restoring my Windows to get LEDs on the RAM to look pretty! LOL, but that it where I am at.


Community Manager
Community Manager
Head over to the issue reporting thread and fill in the form, we'll help you sort it out.
FPS, Racing & VR Gamer / Tech Enthusiast / ROG Admin

I remembered I had a Windows 10 hard drive in my system that was no longer being used and it had an older version of Armory Crate on it.
I disabled my primary Windows 11 drive and booted into Widnows 10.
As expected, Armory Crate worked like a champ and detected my Viper Steel RAM modules and applied the various color effects correctly.

I did some Windows 10 updates and of course even though I told Armory Crate NOT TO UPDATE, I was forced into doing the update after the Windows 10 update. To my surprise Armory Crate continued to work correctly. UNTIL!!!

I went though and updated the various modules of Armory Crate and when I got to the:

ASUS Framework Service
V dated 7/28/2022

That is when it stopped recognizing the Viper Steel RAM modules.
Because there is NO WAY to return to an older version, I am now stuck with my RAM in Rainbow Mode. I can't even turn it off.

ASUS Techs had stated the RAM modules were at fault and to contact Patriot support BUT this clearly shows the PROBLEM lies with Armory Crate and the current ASUS Framework Service v

We need a FIX ASAP. This software has been flaky since I got the system nearly a year ago.

Darvin Atkeson
Windows Support Engineer

Level 10
I use g-skill rgb memories but it seems from this video that G.SKILL Trident Z Lighting Control could be compatible with other brands.
Moreover, for my g-skill memories to appear in Aura Sync from AC, I must install G.SKILL Trident Z Lighting Control.