cancel
Showing results for 
Search instead for 
Did you mean: 

UserSessionHelper.exe high CPU usage in 5.4.8.0

kreizee
Level 7
After a new update UserSessionHelper.exe consumes too much cpu. It is a known bug and still not fixed.

I can't delete the file as I have S17 laptop and without it some keyboard keys just don't work like aura or rog button
22,013 Views
67 REPLIES 67

kreizee
Level 7
How can I rollback to previous version of armoury crate?

ishume
Level 7
Opening Armoury Crate triggers the User Session Helper to consume a lot of CPU resources (from 7-10% of a 7900X).
The process continues to consume CPU after closing Armoury Crate, only solution for me is ending the process in task manager.
Ending the process while having the app open does not affect the program.
97139

Same issue here. But if I dare to press on device in armory crate and chose one of those options, then the helper is back to eating 12% CPU like there is no tomorrow.

The current fix is closing armory crate, ending the helper task in task manager and opening armory crate again.

Same issue:

Rog Strix X670e-a
7900X

Dragg0n wrote:
Same issue here. But if I dare to press on device in armory crate and chose one of those options, then the helper is back to eating 12% CPU like there is no tomorrow.

The current fix is closing armory crate, ending the helper task in task manager and opening armory crate again.


For me, if I open AC again it starts to load cpu same as before

Same problem here.. we need a fix

Same issue here noticed it today after the latest update. Also on an AMD processor 7950x. Would also like to say closing armoury crate, then terminating the process and starting it up again does not fix the issue it just starts up the process once more.

I'm using a rog strix g35cg and in any setting its the same. runs very hot. don't matter what i do
i just stopped the armour crete debug through system task manager and its running normal

i also have found if you goto armour create services with the red wave symbol named : armour create user service and right click , set to efficiency .
this cuts usage and cpu temp by 50%

Same issue. They found the cause of the problem and they will fix with patch soon. I hope..