cancel
Showing results for 
Search instead for 
Did you mean: 

UserSessionHelper.exe high CPU usage in 5.4.8.0

kreizee
Level 7
After a new update UserSessionHelper.exe consumes too much cpu. It is a known bug and still not fixed.

I can't delete the file as I have S17 laptop and without it some keyboard keys just don't work like aura or rog button
558 Views
67 REPLIES 67

Thanks for sharing this. However when I tried this , it did NOT seem to make a difference to Armoury Crate User Session Helper. I am still seeing it pegged to 7% of the CPU just like it was before and causing the machine to warm up and spinning the fan even in silent mode.

Saaji wrote:
I have explained a fix for people who don't want to wait
https://www.reddit.com/r/ZephyrusG14/comments/10srjsa/armourycrateusersessionhelper_hight_cpu_usage_...

Fix Steps

1. Open folder C:\Program Files\ASUS\ARMOURY CRATE Service (where your Armory Crate is installed)

2. Delete (or move to a backup folder) an AC_FDSPlugin folder (you may confirm admin permissions there)

3. Reboot!

Voila, now ArmouryCrate.UserSessionHelper should stay calm in a background. Unlike killing process every time, this fix seem to be permanent!

MasterC
Community Admin
Community Admin
Issue Resolved

Guys, please DO NOT delete program files. The same version cannot be installed again once deleted if the system thinks an update isn't required, uninstallation (using our tool) is necessary in such a case.

ArmouryCrate.AC_FDS v5.4.7.0 was released to resolve the high CPU usage issue.

The update should run as a background process. You may check the version by going to

[Notebooks] C:\Program Files\ASUS\ARMOURY CRATE Service\
[PC] C:\Program Files\ASUS\ARMOURY CRATE Lite Service

and run the executable file ArmouryCrate.InstallationInformation.

Make sure that ArmouryCrate.AC_FDS is on version 5.4.7.0, if not, then check for updates.


Saaji wrote:
I have explained a fix for people who don't want to wait
https://www.reddit.com/r/ZephyrusG14/comments/10srjsa/armourycrateusersessionhelper_hight_cpu_usage_...

Fix Steps

1. Open folder C:\Program Files\ASUS\ARMOURY CRATE Service (where your Armory Crate is installed)

2. Delete (or move to a backup folder) an AC_FDSPlugin folder (you may confirm admin permissions there)

3. Reboot!

Voila, now ArmouryCrate.UserSessionHelper should stay calm in a background. Unlike killing process every time, this fix seem to be permanent!
_____________________________________________________________
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin

MasterC@ROG wrote:
Issue Resolved

Guys, please DO NOT delete program files. The same version cannot be installed again once deleted if the system thinks an update isn't required, uninstallation (using our tool) is necessary in such a case.

ArmouryCrate.AC_FDS v5.4.7.0 was released to resolve the high CPU usage issue.

The update should run as a background process. You may check the version by going to

[Notebooks] C:\Program Files\ASUS\ARMOURY CRATE Service\
[PC] C:\Program Files\ASUS\ARMOURY CRATE Lite Service

and run the executable file ArmouryCrate.InstallationInformation.

Make sure that ArmouryCrate.AC_FDS is on version 5.4.7.0, if not, then check for updates.


Thanks MasterC!

Also there should be one today for Armory Crate Aura 5.4.8.2
Learn, Play Enjoy!

After last update (to 5.4.8.0) I see the usage of CPU and log in C:\AacKBSetup to trace any USB keyboard TUF

[2023-02-07 20:09:57.862][1.2.23.0][27920] [AacTUFK7Function][ChangeKey]
[2023-02-07 20:09:57.893][1.2.23.0][27920] [AacKbFunction_Base][SetProfile]
[2023-02-07 20:09:58.79][1.2.23.0][27920] [AacTUFK7Function][ChangeKey]
[2023-02-07 20:09:58.111][1.2.23.0][27920] [AacKbFunction_Base][SetProfile]
[2023-02-07 20:09:58.298][1.2.23.0][27920] [AacTUFK7Function][ChangeKey]
[2023-02-07 20:09:58.329][1.2.23.0][27920] [AacKbFunction_Base][SetProfile]
[2023-02-07 20:09:58.519][1.2.23.0][27920] [AacTUFK7Function][ChangeKey]
[2023-02-07 20:09:58.549][1.2.23.0][27920] [AacKbFunction_Base][SetProfile]
[2023-02-07 20:09:58.740][1.2.23.0][27920] [AacTUFK7Function][ChangeKey]
[2023-02-07 20:09:58.773][1.2.23.0][27920] [AacKbFunction_Base][SetProfile]
[2023-02-07 20:09:59.71][1.2.23.0][27920] [AacKbEffect_Base][SetStatic]
[2023-02-07 20:09:59.102][1.2.23.0][27920] [AacKbFunction_Base][SetProfile]


Any solutions?

Same here!
Every gamer has suffered from small-screen videos

Mardorr
Level 9
I have the same... Asus ROG Maximus Z690 Extreme mobo.

In Task manager I end ARMOURY CRATE User Session Helper and in 5-10 seconds it automatically restarts and then drops down to 0% CPU usage.

But this doesn't help me get back my CPU temp on the wheel image on left side, I dont want to see the Freq there!

KneelbfZod
Level 9
Yep same here. This is a new problem. Hovers around 5 - 10% CPU at all times now.

Same here. 6-13% on an Intel i7-12700KF overclocked to 5300.
Have a Good One! 😎
Rooke

Got the same problem. After last update, this process uses around 10% CPU all the time. Have to end it, and after start again, It works.