cancel
Showing results for 
Search instead for 
Did you mean: 

UserSessionHelper.exe high CPU usage in 5.4.8.0

kreizee
Level 7
After a new update UserSessionHelper.exe consumes too much cpu. It is a known bug and still not fixed.

I can't delete the file as I have S17 laptop and without it some keyboard keys just don't work like aura or rog button
673 Views
67 REPLIES 67

MasterC@ROG wrote:
We have found the root cause, it's related to Steam's latest update. A patch will be available very soon.

Even when the Steam client isn't running? Is AC sharing one of Steam's .dlls?
Have a Good One! 😎
Rooke

MasterC@ROG wrote:
We have found the root cause, it's related to Steam's latest update. A patch will be available very soon.


What if I do NOT have steam running at all? I never let steam start on startup.

Same...17% cpu usage...

Same problem! Laptop G513QM
97199

And additional after update, Armoury Crate detect CPU temp not less than 70 degrees in idle. Due to this, the coolers are noisy in idle time on the desktop. But in the task manager you can see the real temperature. Fix this pls. I reinstalled Armoury Crate and installed it again according to the instructions with Uninstall file)
97200

97201

PS: after killing User Session Helper, coolers began to work normally and adapt speed to temperature. But when I call Armory Crate through the button or icon again, the User Session Helper again starts to load the CPU and the operation of the coolers becomes incomprehensible. Looks like a bug in the CPU temperature values, since the idle temperature is constantly 70+- degrees in idle. Hoping for a quick fix on this. :rolleyes:

I have the same problem with this update. Temps are high, fans are noisy. I hope there will be a fix soon.97202

same with me. 8-10% on my G513QM. I have to kill it manually via task manager every time I launch armoury crate. please fix

faisal.v8 wrote:
I have the same problem with this update. Temps are high, fans are noisy. I hope there will be a fix soon.97202

This is fake temp, visal bug maybe, check temp in Task manager.

Same issue,Intel CPU, happens after latest update, nothing i found in internet help(logout from user profile and disable AC on background from windows) i have to kill the session everytime after i start AC.

I have explained a fix for people who don't want to wait
https://www.reddit.com/r/ZephyrusG14/comments/10srjsa/armourycrateusersessionhelper_hight_cpu_usage_...

Fix Steps

1. Open folder C:\Program Files\ASUS\ARMOURY CRATE Service (where your Armory Crate is installed)

2. Delete (or move to a backup folder) an AC_FDSPlugin folder (you may confirm admin permissions there)

3. Reboot!

Voila, now ArmouryCrate.UserSessionHelper should stay calm in a background. Unlike killing process every time, this fix seem to be permanent!