cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to update TUF K3 (Error code: 4151)

Cl3udiaaa
Level 8

Heya! I can’t update my armoury crate, it shows ‘Sorry, we cannot finish the file installation. Please restart the system and retry. (Error code: 4151)’. By the way, my device is Asus TUF A15 Ryzen 7 4000 series. When I insert my Asus TUF gaming keyboard K3 and update it on the armoury crate, it shows the said error.

Thanks and have a good one!

9,889 Views
16 REPLIES 16

Coocit
Level 7

I'm in the same situation, man. Did you fix it?

Hey hey! The issue still occurs, already tried basic troubleshooting tho, but still no dice! Any idea how to fix it?

xxxstickxxx
Level 8

Same problem. Mine was working with Armoury Crate until I used the update center. Update failed with same as above and now it wont sync. If I had a dollar for every time these led enabled devices wasted my time, I'd be rich!

Did you figure it out? 

No not really, I uninstalled Armoury Crate, ran ccleaner to clean up my registry, and reinstalled Armoury Crate. This did allow me to see my keyboard and control the colors again but it still says there is an update for the keyboard which I am ignoring this time. Lesson learned. 😐

Paul35
Level 7

Bonjour, 

Je suis dans le même cas... Avez vous pu trouver une solution? 

Il s'agit de mon clavier ROG Strix qui ne veut pas se mettre à jour... 

Cl3udiaaa
Level 8

Still no dice! Can’t figure out why I can’t sync my keyboard. 😐

Cl3udiaaa, if you haven't tried using ccleaner to clean your registry, it got my keyboard synced again. Just google ccleaner. (the free version is what I use and you can uninstall it when you are done.)

  1. uninstall Armoury Crate
  2. download and run ccleaner and look for the option on the left side called "registry"
  3. run that and let it fix everything it finds. There will likely be a bunch of stuff left behind by asus...
  4. reinstall Armoury Crate. Hopefully after a reboot you will be able to see and sync your keyboard.
  5. Ignore the update available for your keyboard and give asus some time to wake up and fix the problem.

I hope that helps you resync with your keyboard, although its not really a fix 🙂

 

Hello! i already tried this but it didn't work on me. i've tried uninstalling my armoury crate many times then used ccleaner but to no avail. please help!