cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to update FanXpert (error code: 238) Armoury crate

dominik_lednick
Level 8

So I'm trying to update my drivers in Armoury crate but I just get this message: "Sorry, we cannot finish the installation. please restart the system and retry. (error code: 238)" Can anybody help?

Also here is screenshot

dominik_lednick_0-1683225343008.png

 

69,023 Views
268 REPLIES 268

LinkinForcer
Level 8

Sad thing is I've never run into an issue before.

I can still run Fan Xpert but the update just won't install. However, I think that the update is already installed. For some reason the program thinks it's not and continues to try and install it giving the error.

uniks84
Level 7

same proble here , win 11

Tomato13
Level 7

Same here windows 10. 

TheJoker1510
Level 7

Im facing the same issue on my new x670e-A Mainboard. same error code 238. I also reinstalled all drivers and armory crate multiple times

3DG
Level 10

2023-05-12 (8).png

 

FanXpert UPDATE ERROR CODE: 238 😡

FanXpert \ Device SDK \ Version 1.00.67 \ Date: 2023/01/03
"Sorry, we can't finish the installation. Please reboot the system and try again. (error code: 238)"

System formatted this week with Windows 11 Pro For Workstation 64Bits, with all Drivers updated from MoKiChU (thank you always friend) and perfectly installed, last Drive of NVidia installed, perfect system, clean without any program installed yet and in the first installation of this ****** Armoury Crate, I already have this ridiculous problem, idiotic and regrettable caused by this FanXpert. Seriously, I will not buy ASUS anymore, you guys are a bad joke! And now what to do? Format and start all over again? Because these attempts and mistakes made, who can guarantee me that the system will work well?

I tried the two methods described here and the error continues, thank you to those who tried to help here, but for me nothing worked.


PyRowMan
Here is what I did for it to work :
1- Install the sdksetup.exe in C:\Program Files\ASUS\RLSDownload\[...].exe
2- Restart computer
3- Install setup.exe in C:\Program Files\ASUS\RLSDownload\[...].exe
4- Remove directory C:\Program Files\ASUS\RLSDownload
5- launch AC and research for updates (at first it showed the install wasn't done)


mozartbl
I follow this path
C:\Program Files\ASUS\RLSDownload\FanXpert
Unzip everything in this path
Install manually
Restart
And its working


My biggest fear:

ChaosDMNS
WTF... I even reinstalled my whole computer... and it still fails...

@asus don't you guys test anything before you release????? Fix this please!!!

Same error. I've spent about 6 hours now uninstalling reinstalling and nothing has worked. 

ASUS B650e-f with bios 1413 (not beta)

Manually running the ask/setup/utility installer/fan service. Stripped the system of nearly everything ASUS and still can't get it to work. If I had seen all the comments about Armoury Crate before I got this board, I would have gone with another brand.

 

Tomorrow I'm stripping it all down, cleaning up what thei uninstall tool leaves behind. Remove the remaining services, maybe drivers and try the 20th time.

3DG
Level 10

I know what you and others go through here, I confess to you that I'm one step away from going into depression, since I bought all the new ASUS parts to assemble this Asus workstation until now it's been several months, first it was the ****** version of BIOS, so with BIOS 2204 things were "fine"... so this week I did everything very calmly, formatting and installing perfect drivers, the workstation was perfect to receive Armory Crate (I only install it and not Aura Creator to avoid more problems, I decided to leave everything without RGB so, to avoid problems, I changed the fans and I have 10 Noctua fans now without RGB)... I use Fan Control for all of them and I only depend on the AC to control the pump and the ROG RYUJIN II 360's display and nothing else. So, after italing and opening Armory Crate, I open FanXpert, and A asks to update and here comes the ERROR CODE: 238 it's sad to see this and already at the beginning of a clean installation this happens... for us that we invest dearly in this equipment, we invest dearly in studies to know how to make perfectly clean installations this is all very sad and discouraging, I speak clearly, that if it weren't for a friend and advisor I made here on the forum and the perfect, clean, updated Drivers and organized from MoKiChU, I had already bought a DELL (I'm thinking of using this strong workstation for 3D work), or MSI, I don't know... that ASUS thing has already gone beyond the limits, I think they will only change when they lose a lot of people crazy people like us who invest fortunes to have the best in hardware... their software sucks, it seems like they never test anything before releasing it, what a pity, disenchantment and tiredness all this, it's a lot of stress and discouraging!

LinkinForcer
Level 8

I'm running a TUF Gaming Z690 Plus WiFi D4 MoBo and I've tried almost everything here with no success. I don't use FanXpert so it's not that big of a deal to me but at the same time I like for all my software to be in order.

 

I had no issues until I did a clean install of Windows 11. I'm not sure where the issue is coming from here but if companies like ESET, Malwarebytes and Macrium can be active in their forum communities to help out, even down to releasing an update to fix a wide spread issue within a day or two, you'd figure Asus would be doing the same.

 

Not sure why they leave us out in the dark like this after we spend so much money on their products but it's rather irritating.

svp error for x670e gaming win 11 

I just reset windows and am having this problem. Resetting Windows might have something to do with it.