cancel
Showing results for 
Search instead for 
Did you mean: 

Ryujin II 360 AIO stoped working with latest update to the HAL software

akgis_
Level 10

As title says, there was a update to the Ryu II and my Z790 Apex and after that the LCD and fan controls dont work infinite loading screen.

Please fix this as I dont have control over the fans anymore. I have uninstalled AC with the uninstall tool restated and installed again and didnt fixed, I also power cycled the computer

Picture in attachment with the versions.

If you need anything else let me know!

3,253 Views
27 REPLIES 27

Feroz
Level 8

Same problem here . I uninstalled ryujin drivers but I’m not able to set my display in the aio also armoury doesn’t see my MB 

and in ( My products page ) it show ryujin as 2 instead of ryujin 3 ! Me to I hope they fix this as it’s really uncomfortable thing 

WILBZ11
Level 8

Me too, totally broken after todays update. ASUS please fix rhus ASAP 

tmr01
Level 8

Due to the same phenomenon, Ryujin stops working and enters infinite loading. What on earth did you update?

MarcioTB
Level 9

Same problem here after updated today! And my motherboard is broken too

dayu2011
Level 8

Same thing here. Now pump and embedded fans are running 100% which is very noisy 😕

tmr01
Level 8

As a temporary measure, you can temporarily return to normal by holding off on Ryujin updates (HAL/HTML) after installing the Armory Crate Full Installation Package.

Armory Crate developers don’t have QA or QC? I don't know why a new problem appears every time I update.

How did you get this to work? After you installed full Armoury Crate it will not let you do anything until you update RYUJIN III, after it update it will back to stuck again

Dear dayu2011

This is the method I used:


1. Install the Armory Crate full installation package.
(I have RTX4080/Ryujin 2 360)

2. Automatic updates through Windows Microsoft Store.

3. Update all items in the Update section immediately after installation.

4. It must be used in this state, and if you run the update again,
A problem arises.
Because 'HAL/HTML' was updated on October 25th.
It doesn't click at all.

I hope the problem is resolved well before ASUS resolves it.

Holy moly, it worked, thank you so much for the detailed instructions!!!!