cancel
Showing results for 
Search instead for 
Did you mean: 

Ryujin II 360 AIO stoped working with latest update to the HAL software

akgis_
Level 10

As title says, there was a update to the Ryu II and my Z790 Apex and after that the LCD and fan controls dont work infinite loading screen.

Please fix this as I dont have control over the fans anymore. I have uninstalled AC with the uninstall tool restated and installed again and didnt fixed, I also power cycled the computer

Picture in attachment with the versions.

If you need anything else let me know!

3,869 Views
27 REPLIES 27

I'm so glad the issue has been resolved (albeit temporarily). Have a nice day 🙂😅

Its not been resolved yet , we have different devices you are running ryujin 2 and us ryujin 3 . the bug drive says ryujin 2 ] so maybe it work for you but not for us . Anyway thanks for all the inf its well appreciated  .. we all hope they be more carful next time be Couse an error as  this one can cause fatal damage .example if the pomp stop ? a CPU would burn out and the house with it .     

I have RYUJIN III and it worked for me, this method applies for both II and III. Like tmr01 said previously but I will word it again

0. Uninstall Armoury Crate by using the uninstaller tool from ASUS (https://www.asus.com/supportonly/armoury%20crate/helpdesk_download/)

1. Install the Armory Crate FULL installation package. Same link from step 0. Version 1.2.4.0, 2.93 GB. After you install the app, DO NOT do anything and close Armoury Crate.

2. Go to Windows Microsoft Store app, click on "Library" and update the Armoury Crate to the latest version.

3. After the Armoury Crate app update, open Armoury Crate and click in to the "Update Center". DO NOT click "Check for Updates" as it will show the HAL driver update which causes problem. You should see there're already pending updates for your devices and update all items now.

4. After you install all updates you should be able to control your RYUJIN III agian. DO NOT press check for update at all cost as it will scan live update which will show the HAL driver update.

 

Screenshot 2023-10-28 113008.png

Thanks . I will tray again this afternoon. I know now I have done one step wrong , I punched “check for updates “ then everything returned to the bug update . I know this is a human mistake is ok but God I’m not even using my PC anymore. I’m just trying to fix this problem spending hours just doing that ! 

Fallow every step and the software will auto update everything bringing me to the problem again. I’m just leaving it like this and hoping they they fix it soon . 
thanks mate . 

This doesn't work as I can't select the Ryujin 11 in the list of components to install manually 

How can you do this, when I install Armoury Crate it already installs everything inlcuding the latest upgrade unfortunatly

Can you give more details?

This is what I did, uninstalled Armoury crate > restarted > downloaded armory crate installer again > installed takes a alot of time becuase it auto detects everything I dont do any imput > app restats itself > then Iam already on latest versions including the bugged components for the AIO

 

OK this is how I got it working again.

Download and Install the Armory Crate full installation package from the asus armoury crate website it's a 3GB file.

Remove existing armoury crate with the armoury crate un installer and reboot.

Run windows disk clean up and Cc cleaner.

Run Cc cleaner registry cleaner and reboot.

Install the armoury crate full installation package and pick your asus components on your system from the menu, they should already be highlighted red.

Go to the update section in armoury crate once everything has installed and you will see an update for armoury crate, click update.

Once finished open armoury crate and set up your AIO and other components again.

Avoid clicking the updates button until ASUS roll out the fixed files and they are confirmed to be working 

Thank you very much wasnt aware there was a full package, following this instructions managed to get the AIO controls back

Apreciated.

6136629163
Level 7

Edit: fixed after second uninstall and reinstall. Same problem here. even tried uninstall tool then reinstall. Still blank . Bad update . Hopefully they patch this fast