Showing results for 
Search instead for 
Did you mean: 

Ryujin 2 script error.

Level 8

I have the same error. Unistall with tool and reinstall works until next reboot.

Can´t enter to ryujin´s page on Armory Crate.

Come on asus! :rolleyes:

denisgcarvalho wrote:
I have the same problem... what will be the solution?

There are three possible solutions at this point.
(1) Uninstall AC (using ASUS' AC uninstall tool), reboot, use "windows cleanup" to delete all temporary files, then reinstall AC. Note that you may have to try reinstall multiple times as it frequently fails and says "check your internet" when nothing is wrong with your internet.
(2) Wait for ASUS to provide a fix.
(3) Abandon AC. Uninstall it using ASUS's AC uninstall tool, and replace it with a generic fan control system. This is not a complete solution, as there are specific proprietary devices (I'm looking at you, Ryujin-II) that only AC can control.

Option #1 worked for me! But it has failed for others, or worked only temporarily with problems returning upon reboot.

Option #2 is only for the very patient and most optimistic among us.

Option #3 is what I would choose *IF* you don't have any hardware that only AC can control.
Z690-E, i9-12900k, 2x16 DDR5, 980pro nvme x3, Ryujin-II 360, Strix Animate-II, Evga 3090 ftw3

i get a script error as well but its armoury crate all together i reinstalled it fixed until i installed updates then it came back again. can anyone tell me how to fix.

BRYANM72 wrote:
i reinstalled it fixed until i installed updates

Which updates brought back the problem? Was it a Windows Update? Or an Armoury Crate Update?

It would be helpful to know the module/service names and versions (if Armoury Crate) or the update name (KB number) if Windows.
Z690-E, i9-12900k, 2x16 DDR5, 980pro nvme x3, Ryujin-II 360, Strix Animate-II, Evga 3090 ftw3

I am also having this problem. I just installed my Ryujin II today.

It's a little bit worrying, I can't access the settings paqe for it through Armoury Crate either.

Level 8
Solved for me.

Level 11
With the New latest ASUS HAL Update this error should have been fixed. Go to ASUS AC for updates.

Or you have NET Framework 3.5 still deactivated because ASUS AC accesses it. Because Microsoft has disabled this in the last updates!
In Windows 10 and 11 under Windows Features (Search), first tick .Net Framework 3.5 and press OK and continue. Restart and everything should work again.
AMD Ryzen 9 7950X3D | ROG CROSSHAIR X670E EXTREME | ASUS TUF Gaming GeForce RTX 4090 OC | G.Skill F5-6000J3040G32GX2-TZ5N | WD Black SN850X | PHANTEKS Glacier One 360 T30 Gen2 | LG OLED42C27LA | Phanteks NV7 | Seasonic PRIME-TX-1300 | Windows 11 Pro.

Woohoo! I can confirm that the latest updates have fixed it! 😄

My Ryujin II 360 now works as it should. You, whoever you are, have my gratitude.