Showing results for 
Search instead for 
Did you mean: 

ROG Spatha HAL update failure

Level 7
Title says it all,
My Spatha won't update the HAL and can't be controlled in crate until it does.

Steps tried...
Have tried using tool to fully uninstall crate several times.
Independently updated the bios on the Spatha
Tried wired and wireless options of the above.

I'm at a loss of what to do sadly so any help would be appreciated.

No error codes just a little red warning after each attempted update.. see attached pic

Cheers for your attention.


Hello esgargoth

Connect the USB cable to your mouse and pc, on the bottom of the ROG Spatha turn the power switch off.

Then try the update in Armoury Crate.

Nate152 wrote:
Hello esgargoth

Connect the USB cable to your mouse and pc, on the bottom of the ROG Spatha turn the power switch off.

Then try the update in Armoury Crate.

Hi and thanks for the reply, it didn't occur to me to switch it off and to be fair i did get a bit further however it is sitting right at the end and has been for the past three hours.
I'll try removing armoury completely and reinstalling then see how it goes and update.

Cheers again.

Level 7
Yea it didn't work sadly.
Still just back to ignoring the install... 😞

All right,

Since you want to reinstall Armoury Crate, use the uninstall tool.

Let the cable connected to your mouse and pc with the switch on your ROG Spatha set to off.

In the link below, select your operating system then click "Show all" in blue, the uninstall tool is the third download.

Once uninstalled, install Armoury Crate version and check for updates at the Update Center.

Does this get your ROG Spatha updated?

Level 7
Tried it and rebooted several times, still didn't work and even worse is now half the devices are missing including the motherboard ....
what a joke. anyway i have to work so i'll come back to this tomorrow.

Ok, sorry to hear that didn't work.

Try this:

Use the uninstall tool again to uninstall Armoury Crate.

Install and run CCleaner (free version) to clean up any files, then click the registry tab and clean that too.

Reboot your pc.

Install Armoury Crate version and check for updates at the Update Center.

Let me know if this gets your ROG Spatha updated, you can reply when you get a chance.

Level 7
Still not working after trying the cccleaner.. (sad face)

esgargoth wrote:
Still not working after trying the cccleaner.. (sad face)

I had the same error with my ROG Spatha mouse. yesterday.

This is how I solved it:
- Before starting anything, turn off all tuning options in BIOS,
- Turn off Aura control in the menu accessible with the F4 key (AUROA Off)
- Start the Windows in normal mode,
- Download and unzip the Armoury Crate Uninstall Tool from this link:
- Run the uninstall tool. After uninstall restart the computer,
- CCleaner is not necessary.
- Install all update with Windows Update and restart Windows every installed update,
- Connect the SPATHA with cable to USB port, do not use the wireless mode!
- Download the Armoury Crate full installation package (1.73GB) from this page: and unzip in a folder or pendrive.
- Disable the network card , or unplug ethernet cable (internet cable) from computer and disable bluetooth too, and restart computer.
- After restart start the Armoury Crate installation package and be patient. 🙂 If install is done, do not click to start Armoury Crate , restart computer (this is important)
- If restart is ok start Armoury Crate and check your mouse (you see the settings, lights, etc.)
- Enable the network card (or plug in the ethernet/internet cable) and enable bluetooth too. Restart computer.
- After restart wait 1-2 minutes and start the Armoury Crate. Click on Settings - Update Center. If everything is in order, this interface is divided into two areas. In the meantime, the update warning pops up. DO NOT refresh and click to avoid warning again. In the lower area you will see a list of upgradeable options. SPATHA should appear here. If the HAL is visible in several lines, update only the HAL visible at SPATHA (It appears under SPATHA)!!! Click on update and wait. After update restart computer again and enable in the BIOS the aura lights (Aura ON). Save the changes and restart computer.
- Windows started, wait 1-2 minutes and start Armoury Crate and check your mouse. I think everything must be fine!

I dont know what happen at the end if you connect again with wireless mode, but i think must be correct.
Hope will work correctly!

Best regards,
( sorry my english, i am hungarian 🙂 )

Level 7
Thank you and sorry to say it didn't work.
Tied 8 times and now i'm just sick of it.
Just installed the stand alone armoury and disabled all rgb.
Thank you anyway.