Showing results for 
Search instead for 
Did you mean: 

ROG Ryujinn II 360mm AIO

Level 7

So I have a ROG Ryujin II 360mm AIO or had I should say, I got the Ryujinn III and I decided to give my Ryujinn II to my friend. He just got an i9-13900k and z790 maximus hero board, For some reason no matter what we do my old gif I had on the Ryujin II is on there still and armory crate will not detect it. The pump runs and is cooling his CPU however functionality with armory crate is non existent. 

mini usb is plugged into rog fan controller that came with Ryujin II, sata is plugged into the fan controller and his usb 2.0 connection is correctly plugged into his board.

I have tried to uninstall armory crate and reinstall, tried uninstalling and reinstalling the full install version (selecting Ryujin II in the component list), no unknown devices in his device manager and the controller is labeled "aura fan controller". I have also tried different usb 2.0 connections on his board same thing it still shows my old gif on the lcd screen. Is there something I'm missing?



Level 7

Edit** Everything updates in armoury crate involving his mother board/fan xpert under devices however nothing else shows up and when we check for update the Ryujin II still isn't detected.