cancel
Showing results for 
Search instead for 
Did you mean: 

Rog Gladius II Origin - Firmware Update Fails, Error code 12

MEZesUBI
Level 7
Just recently I clean installed (removed, used uninstaller to remove residue, reinstalled) Armoury Crate on my pc, as I had issues installing the new firmware of my Gladius II Origin.
With the clean installed Crate I'm still unavailable to do so. The download bar loads immediately, install bar hangs a bit, then cancels with the exclamation mark on the Install button, stating that the system needs restarting, error code 12.

  • I tried installing with restarted system
  • I tried installing having the mouse plugged into different USB ports too

Same issue occurs.
I was also able to find this issue reported on Armoury Crate v5.0.11.0 [Report here if any issues], but there was no solution provided.

System specs:
Windows 10 64 bit, all updates installed
Strix B550-E gaming edition
AMD Ryzen 5600X
32 GB Kingston Fury Renegade (4x8)
Gigabyte 3070 Gaming OC

I cannot tell if any other startup services / drivers might be interfering with the installation of this specific mouse firmware update, I can only tell that such failure didn't occur with any other of my Asus devices (Mobo, Claymore keyboard).

Could you please tell me if this is a known issue which being is worked on or if there's a different way to fix this?

Many thanks!
951 Views
0 REPLIES 0