cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with 5.2.12 Update

TianaV
Level 7
Hi, so I am having a problem with the newest Armoury Crate update.
1. The major problem: None of the dashboard features are working properly (in the screenshots I'll be providing, you can see that it's not listing anything under the 'Frequency' tab), and I figure that's because the software detects my devices and then 'undetects' them. I'll provide some screenshots below.
2. The minor problem: When I just opened the app, this problem didn't occur, but following the update, when I opened the app it took a good minute to get past the 'loading' part.

Some things to bear in mind:
1. I just made this PC (it's only been around 2-3 weeks) and before this update, the AC lighting service had a bug under the 'devices' tab for my motherboard where it would always pop up with 'Lighting Service is busy. Please try again later.' It was just with the motherboard, as under the 'devices' tab for my graphics card, I was able to open it just fine.
2. When I contacted the ASUS support about the above problem, they asked my to troubleshoot it, and prior to that chat I didn't know there was an uninstall tool for the app. So, I had manually uninstalled part of the program before using the uninstall tool.
3. As of right now, I've uninstalled and reinstalled AC quite a few times to try and fix the problems I've been facing.
4. Prior to the update, after I reinstalled AC the first time, it wouldn't let me update to the 5.1.5.0 (or whatever was prior to this one).

For extra information, here is the overall app versions:
Item Version
---- -------
Armoury Crate UWP App 5.2.12.0
ROG Live Service 1.5.10.0
Aura Service (Lighting Service) 3.05.66
Armoury Crate lite service 5.2.10
Aura Wallpaper Service Not installed
AacVGA 0.0.5.2
ASUS AURA Extension Card HAL 1.1.0.18
ASUS AIOFan HAL 1.1.47.0
KingstonDram 1.1.12
ASUS AURA Motherboard HAL 1.3.4.0
ENE RGB HAL 1.1.39.18
AURA DRAM Component 1.1.18
Patriot Viper DRAM RGB 1.0.9.4
ENE_DRAM_RGB_AIO 1.0.3.37
PHISON HAL 1.0.9.0
Patriot Viper M2 SSD RGB 1.1.0.2
WD_BLACK AN1500 1.0.14.0
ENE_EHD_M2_HAL 1.0.9.12
Universal Holtek RGB DRAM 1.0.0.3

Any input or help would be appreciated!
7,847 Views
50 REPLIES 50

Nate152 wrote:
Thank you for trying the Armoury Crate uninstall tool.

I may suggest to do a clean windows reinstall, this will fix the problem.

I'm using the ROG Strix Z690-F Gaming Wifi motherboard.

Click the picture to make it bigger.

94507


Though a few people have commented otherwise, I'd still like to ask you again, is this a guaranteed fix? And if so, is it also a permeant fix or is it possible for it to happen again in the next update?

TianaV wrote:
Though a few people have commented otherwise, I'd still like to ask you again, is this a guaranteed fix? And if so, is it also a permeant fix or is it possible for it to happen again in the next update?


Dont bother. You're going to want to rip all your hair our when you realize youve reinstalled windows and spent hours or even days reinstalling all your current programs just to find out the Armory issues are exactly the same.

Nate152
Moderator
There are a number of things that can cause problems with Armoury Crate.

I will suggest to reset the bios to defaults, update to the latest bios version, then reinstall windows.

You will need to install the chipset driver for windows 11, check device manager for any missing drivers.

I can confirm reinstalling windows is a guaranteed fix.

Nate152 wrote:
There are a number of things that can cause problems with Armoury Crate.

I will suggest to reset the bios to defaults, update to the latest bios version, then reinstall windows.

You will need to install the chipset driver for windows 11, check device manager for any missing drivers.

I can confirm reinstalling windows is a guaranteed fix.


But is it permanent?

Nate152 wrote:
I can confirm reinstalling windows is a guaranteed fix.

But is it..?
I can see many people saying that it didn't work. Also, reinstalling Windows because of a messed up AC update, are you serious?

Nate152
Moderator
I did have an issue where my pc was slightly unstable and was causing problems with Armoury Crate.

It took resetting the bios to defaults and reinstalling windows to fix it. It was my own negligence of an unstable pc is why I was having problems.

I'm using the latest version of Armoury Crate, after stabilizing my overclock and memory, all has been working fine.

94510

Okay, but I don't think my PC is unstable because I've never overclocked it, so I don't know if it'd be the same reason for my problem.

Before I do any BIOS resets or Windows reinstall, I would like an answer to my previous question. If you don't have a for-sure one, that's fine, just say so. I'd just like to know. So, will this 'fix' work permanently? Or is there even a slight possibility that I could face the same problem after the next big update?

I don't want to sound pushy, but as I said before, this seems like a lot of work for a solution that might not be a permanent fix.

Nate152
Moderator
Well, after stabilizing my overclock I haven't had any issues.

I've been using the latest version since release and everything with Armoury Crate is working fine.

Since I haven't had any further issues, I can say yes it is a permanent fix.

Okay, then assuming I decide to takes this approach, could you explain to me how to perform a BIOS reset and Windows reinstall?

Nate152
Moderator
To reset the bios with ASUS motherboards, enter the bios and hit the F5 key.

Download windows 11 onto a 16GB usb flash drive, then set the flash drive as the first boot device. Hit F10 and Enter to save and exit, your pc will reboot and start the windows installation.

Choose the option "Create Windows 11 Installation Media"

https://www.microsoft.com/en-us/software-download/windows11?9d47a9e1-e53b-49a1-92ca-a647d62dc410=Tru...