cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with 5.2.12 Update

TianaV
Level 7
Hi, so I am having a problem with the newest Armoury Crate update.
1. The major problem: None of the dashboard features are working properly (in the screenshots I'll be providing, you can see that it's not listing anything under the 'Frequency' tab), and I figure that's because the software detects my devices and then 'undetects' them. I'll provide some screenshots below.
2. The minor problem: When I just opened the app, this problem didn't occur, but following the update, when I opened the app it took a good minute to get past the 'loading' part.

Some things to bear in mind:
1. I just made this PC (it's only been around 2-3 weeks) and before this update, the AC lighting service had a bug under the 'devices' tab for my motherboard where it would always pop up with 'Lighting Service is busy. Please try again later.' It was just with the motherboard, as under the 'devices' tab for my graphics card, I was able to open it just fine.
2. When I contacted the ASUS support about the above problem, they asked my to troubleshoot it, and prior to that chat I didn't know there was an uninstall tool for the app. So, I had manually uninstalled part of the program before using the uninstall tool.
3. As of right now, I've uninstalled and reinstalled AC quite a few times to try and fix the problems I've been facing.
4. Prior to the update, after I reinstalled AC the first time, it wouldn't let me update to the 5.1.5.0 (or whatever was prior to this one).

For extra information, here is the overall app versions:
Item Version
---- -------
Armoury Crate UWP App 5.2.12.0
ROG Live Service 1.5.10.0
Aura Service (Lighting Service) 3.05.66
Armoury Crate lite service 5.2.10
Aura Wallpaper Service Not installed
AacVGA 0.0.5.2
ASUS AURA Extension Card HAL 1.1.0.18
ASUS AIOFan HAL 1.1.47.0
KingstonDram 1.1.12
ASUS AURA Motherboard HAL 1.3.4.0
ENE RGB HAL 1.1.39.18
AURA DRAM Component 1.1.18
Patriot Viper DRAM RGB 1.0.9.4
ENE_DRAM_RGB_AIO 1.0.3.37
PHISON HAL 1.0.9.0
Patriot Viper M2 SSD RGB 1.1.0.2
WD_BLACK AN1500 1.0.14.0
ENE_EHD_M2_HAL 1.0.9.12
Universal Holtek RGB DRAM 1.0.0.3

Any input or help would be appreciated!
6,605 Views
50 REPLIES 50

Okay, and then what about updating to the latest BIOS? I've heard that there are risks associated with that if something were to happen (like a power outage).

Nate152
Moderator
True, you don't want to lose power when updating the bios, but you can always reflash it if this happens.

Insert a usb flashdrive into a usb port on your pc.

Go to the ASUS Support Center, search your motherboard and click Driver & Utility.

Click Bios & Firmware.

Click Download in red to the right of the bios version.

Once downloaded, extract the files to the usb flash drive.

Reboot and enter the bios, go to the EZ Flash tab, find your usb flash drive with the bios and click on it. It will ask if you want to update the bios, click yes and the update will begin.

Here is a video how to put the bios file on a usb flash drive.

First, is there necessarily a 'right' BIOS version, or would I just choose the latest one?
Second, what is reflashing? And how would I do it if a power outage did occur?

Honestly, I'm only considering this option because I recently built this PC (like 3 weeks ago) and it wouldn't be too much a pain to reinstall stuff since I've yet to install too many things besides software related apps and a few games. However, in saying that, I also don't want to 'brick' the PC since I just built it and it wasn't exactly cheap.

Nate152
Moderator
If done properly, You won't brick your pc.

Reflashing is a name for reinstalling the same bios version. If the power went out, you'd wait until it came back on then proceed with the bios update.

It's always a good idea to update to the latest bios version mainly for compatibility.

So, if the power went out mid-BIOS update, I would just wait until the power got restored and then try to update it again? But if the power went out mid-update wouldn't that brick it? Or does a PC get bricked in a more specific way when you're updating the BIOS? (Sorry, this is like the first time I'm doing any of this. I had a fossil PC prior to this new PC.)

Anyways, I'll consider doing this, and I'll probably have my friend assist me to make sure everything gets done properly. But I think I'll wait until after I get a response to the forum I submitted for the Administrator's latest post. If it can be fixed in a different way, I'll try them out before resorting to these means.

Nate152
Moderator
If the power went off during the update, the motherboard would likely be bricked, you'd wait til the power came back on and then update the bios, all would be back to normal.

I'd do things in this order.

1) Update the bios.
2) Install windows 11.
3) Install the Chipset driver for your motherboard.
4) Install the Realtek audio driver if your headset/speakers don't require Armoury Crate. If your speakers/headset require Armoury Crate, skip this step.
5) Install the Bluetooth driver if you use it.
5) Update the graphics driver.
6) Update windows.
7) Install Armoury Crate version 3.2.2.3, go to the update center and run all the updates.

Do I find the chipset driver on the ASUS download page?
Where would I find the realtek audio and bluetooth drivers?
And I assume the graphics driver would be through Nvidia's app?

Nate152
Moderator
Correct, I see you're going to reinstall windows.

You'll get all drivers for your motherboard from the ASUS Support Center.

https://www.asus.com/support/Download-Center/

You'll get the latest Nvidia driver from the Nvidia driver downloads page, the latest driver is 516.59.

https://www.nvidia.com/Download/driverResults.aspx/190552/en-us/

If you'd like some help, please list me your motherboard.

Did you get the bios updated?

Ah, well I haven't decided on anything yet. I'm just asking for future reference if I do decide to go through these steps.
Anyways, my motherboard is the TUF Z960-PLUS WIFI D4.
And since I'm waiting, no I have not updated the BIOS, currently I have the 0707(?) one.

Also, I just remembered that I don't have the AI Suite 3 thing installed, do you think that'd by the reason why I'm having this problem?

Nate152
Moderator
Thank you for your motherboard model.

I wouldn't recommend installing AI Suite III if you're using Armoury Crate.

What are you using for audio, tell me the brand and model of your headset/speakers, this will determine if you need the Realtek audio driver.