cancel
Showing results for 
Search instead for 
Did you mean: 

No Rollback options?!

ph0b0s123
Level 8

So Ver 5.7 of AC has now dropped, bringing with it a list of issues unfortunately. This is stuff that was working in the previous version, now not working.

This would be fine if you had the option to roll back to the older version that was working for you. With AC though this is not an option as the installer is an online one and ASUS having no full package / offline installers for older versions. The only full installer on the website if for ver 1.4.

Is it me or is this not really acceptable. So, if you have the misfortune to have updated whether on purpose or not, the only option you have to get things working again is reliant on Asus fixing the issue, if they ever do. When I say on purpose or not, I wanted a Netflix update on the Windows Store that was not showing (I have auto updates disabled) and selected 'get updates' which updated everything, including AC (ARRGHH) and then came the pain.

Would not mind if I could just de-install the latest version and install the last version that was working fine. How is this not an option?! This 'gold fish memory' of the old version never existing, does not really cut it....

142 Views
3 REPLIES 3

ph0b0s123
Level 8

With all the threads on here about issues with ver 5.7 and the only option for most, appearing to be, having to wait for Asus to provide a fix. I don't get then why there is not more of a push by people to be able to solve it themselves, in the short term, by the work around of rolling back to a working version, until Asus get round to fixing your issue. Would not being able to go back to say 5.6, to restore functionality, be a desired option in such cases? No software is perfect, so even with the best QA, issues can get through that can be a major pain with an update, so I certainly belive there should be a roll back option.

ph0b0s123
Level 8

So, something I was not aware of. Full installation package (V5.6.8.0) is still available here:

https://rog.asus.com/us/armoury-crate/

Click 'download', once you have scrolled to it.

ph0b0s123_0-1699539698486.png

Ignore that is says Ver1.1.2.2, that must be the vetrsion of the installer. It delivers AC (V5.6.8.0). It may not have been updated to V5.7 yet due to the problems, but is an option for the moment. What would be better is an archive of older versions though.

Also the fun of running an older version is, at least for me, I get prompted to update every time I go into Fanxpert area of AC as below.

ph0b0s123_1-1699539918905.png

So have to click 'check update', go to update area where it says there is an update, then I can open fanxpert area successfully.

So, there is currently an option for anyone who wants to roll back, but with the caveat above...

Update: The check update box popping up can be resolved by just updating fanxpert module (if you were not having a fan issue with the latest version). Did not know you could update a module on the update page without the overall AC version also being updated. Probably not an advised way of having it, but resolves the above message.

Update 2: That way of just updating two components to stop the popups is no good as a few weeks later those areas, motherboard and fanxpert, stopped working and just showed an infinite loading screen. Rolled back to having to have pop-ups...

ProUser
Level 9

What would be better is an archive of older versions though.

=> That's all we need, installing every older Version and _STAYING_ there w/o popups like on your screenshot. We need an offline-Version of the tool. Because when we get a working version, i would now stay there, w/o updating a working version!