cancel
Showing results for 
Search instead for 
Did you mean: 

Keyboard TUF GAMING K7 lag on startup issue

SunriseLV
Level 8
Hello,

I have problem from long time ago. After installing Armoury Crate, my keyboard Asus K7 suffers from lag at system startup ( when typing for example password, some letters skips ). Problems goes away after Armoury Crate services is fully started ( then keyboard flashes ) and all is ok. And thats every time I start a system.

I have latest software and drivers. Problem was as on Windows 10 and even after upgrading to Windows 11.

I Have tried fully reinstall Armoury Crate, but nothing halps. ( Yes used Armoury uninstall tool )

Without Armoury Crate there is no such issues.

What I noticed, is that the problem happens when Armoury services is starting, for example:

First 10 secounds on system startup everything is fine, then services is starting ( for about 30 secound ) there is problem with keyboard laggy input, and only after every thing is started, problems goes away.

I have good PC ( Ryzen 9 5900x, B550-f MB, 32GB 3200Mhz RAM )

Any suggestions?
395 Views
7 REPLIES 7

Ehs_m83
Level 8
SunriseLV wrote:
Hello,

I have problem from long time ago. After installing Armoury Crate, my keyboard Asus K7 suffers from lag at system startup ( when typing for example password, some letters skips ). Problems goes away after Armoury Crate services is fully started ( then keyboard flashes ) and all is ok. And thats every time I start a system.

I have latest software and drivers. Problem was as on Windows 10 and even after upgrading to Windows 11.

I Have tried fully reinstall Armoury Crate, but nothing halps. ( Yes used Armoury uninstall tool )

Without Armoury Crate there is no such issues.

What I noticed, is that the problem happens when Armoury services is starting, for example:

First 10 secounds on system startup everything is fine, then services is starting ( for about 30 secound ) there is problem with keyboard laggy input, and only after every thing is started, problems goes away.

I have good PC ( Ryzen 9 5900x, B550-f MB, 32GB 3200Mhz RAM )

Any suggestions?


I have the same problem with K7

So I believe issue is generally with every K7 keyboard and Armoury Crate software.

Please release patch for this or suggest us what to do

SunriseLV
Level 8

Update:

I was so frustrated of this bug, that in hope to fix it, I tried reinstall windows, but that didn't give expected result. Also to be sure it's not some weird compatibility issue, I tried keyboard on completely different pc, and still got this bug.

Same thing, while Armoury crate is not installed, everything works fine, as soon this software is installed, bug happens on computer start ( more detailed described in main topic )

SunriseLV
Level 8

Running now latest Software Version 3.2.6.1

Still same issue, any plan to fix it?

SlevinK
Level 7

Same problem here and no solution in sight.
My K7 will be going right back.
ASUS itself was no help at all just forwarding to the help page.

leadq
Level 7

Same issue... Where are you ASUS ? What is solution?

I got still same issue, nothing changed 😞 In the feature I will switch to another brand