Showing results for 
Search instead for 
Did you mean: 

Installation problem with the error code 507

Level 7
It’s impossible for me to install Armory crate that I need for my LED’s to work correctly. I will use it in conjunction with ICUE.

I have downloaded the latest version from Asus and extracted the file. When I press the setup file and the program start it seems to start reading some files because I can see some black windows that pops up quickly on the screen. After just some seconds I get a software related message from Asus that says I should check my Internet connection and with the error code 507. I can’t find any information at all about that specific code so I can’t do any further investigations. I have my PC connected via WiFi and have a stable and fast Internet connection since Internet works great for all other applications. I have also tried the same installation with an Ethernet cable connected but I get the same message about an missing Internet connection. I have updated my BIOS, LAN and Chipset drivers to the latest and*I have also tried to use Armory crate uninstaller several times between the several installation that I have done but it won’t work anyway. I have also left this case over to Asus support as well but we will see if they have any suggestions.

Edit: I have now made a clean installation of Windows 10 instead of Win 11and I have also downloaded the "Full installation" version of Armoury crate. If I am not wrong I shouldn't need any Internet connection to install that way and still I´ve got the same message as before. This is really wierd.

Specs of my PC:
Win 11 with the latest version*
Asus Z-390-A Prime motherboard
4x8GB Corsair Vengeance RGB Pro 3200Mhz RAM
Asus RTX 3090 *TUF GPU
Intel i9 9900K CPU

The attached file are in Swedish.

Level 7

Please tell me you have found a solution to this I am having the same problem and no luck

Level 7

We have almost the exact specs. the only difference is that I have a 3060 instead of a 3090, and I just happen to have the same error message. I(f you get this let me know. There are some other similar problems I'm having and I'm starting to believe its my hardware.