cancel
Showing results for 
Search instead for 
Did you mean: 

I need help with my ROG Harpe Ace Aim Lab Edition mouse

Domnom09
Level 7

Hello, so I recently just bought the ROG Harpe Ace Aim Lab Edition mouse and I did all the updates that it needed today. After some update my mouse dashboard just stopped working and is now showing this:

Domnom09_1-1716051773508.png

I have literally tried everything I could find on the internet. I tried updating my BIOS, uninstalling and reinstalling Armoury Create again, downloading new firmware, rebooting my pc multiple times, removing it from my Device Manager, unpairing it and pairing it again, etc. I have spent almost my entire day trying to figure out what the issue is and resolving it. Please help, I don't know what to do anymore.

219 Views
2 REPLIES 2

Bmichalik87
Level 8

Same exact issue here… tried uninstalling, reinstalling, unpairing, repairing, removing from device manager. Tried armoury crate gear software, same result. This is an issue with the Asus software and they need to acknowledge it and fix it. 

same for me