cancel
Showing results for 
Search instead for 
Did you mean: 

GPU not shown or detected?

McDrift57
Level 7
Hi everyone, I made a user just to post this question. I recently build myself a new PC, but I'm having some troubles with Armoury Crate.

My GPU isn't shown in Armoury Crate nor do I have the option to setup custom/manual fan curves or overclock it or anything. It is simply not shown anywhere.

I have tried reinstalling multiple times. Every driver is the newest. Chipset, GPU, Armoury Crate, Nvidia etc.

Am I doing something wrong?

Specs:
ASUS TUF Gaming B550M-E Motherboard
AMD Ryzen 7 5800X CPU
NZXT Kraken X63 AIO
ASUS GeForce RTX 3070 Dual V2
Kingston HyperX Fury RGB 3600MHz 32GB DDR4 Ram
Samsung 980 PRO M.2 SSD
Samsung 970 EVO M.2 SSD
CoolerMaster Silencio S400 TG Case
2,215 Views
5 REPLIES 5

Rainmaker85
Level 7
Please list full specifications of your rig dude

Rainmaker85 wrote:
Please list full specifications of your rig dude


Sorry, here 🙂

Specs:
ASUS TUF Gaming B550M-E Motherboard
AMD Ryzen 7 5800X CPU
NZXT Kraken X63 AIO
ASUS GeForce RTX 3070 Dual V2
Kingston HyperX Fury RGB 3600MHz 32GB DDR4 Ram
Samsung 980 PRO M.2 SSD
Samsung 970 EVO M.2 SSD
CoolerMaster Silencio S400 TG Case

Have you installed a waterblock on your GPU? When you start your pc do the fans starts on your GPU, along with any lighting? Are you using
the m.2 drives on a pcie expansion card card or on the motherboard?

Rainmaker85 wrote:
Have you installed a waterblock on your GPU? When you start your pc do the fans starts on your GPU, along with any lighting? Are you using
the m.2 drives on a pcie expansion card card or on the motherboard?


No waterblock on GPU. Fans and lighting start yes, and the M.2's are in the two motherboard slots. Graphics card works fine everywhere else but Armoury Crate..

No one?