Showing results for 
Search instead for 
Did you mean: 

G SKILL TRIDENT Z ram/ RGB lighting freezes after a variable amount of time

Level 9

Since the last update my ram sticks seems to not be able to work correctly.
After boot up they get synced up with the rest of the hardware (except for the GPU but that's a known issue).

after that the lighs will usually get stuck and remain so until  the system gets rebooted. Sometimes opening Aura Creator or Armoury crate will make the rgb lights flash across all the devices and then resync the ram by itself, sometime it doesn't. It's extremely inconsistent and thus hard to identify. Only thing I noted is that during the last round of uninstall/reinstall the lighting control software (Armoury crate and G skill trident Z lighting control) there was a window of time where the pc had only the G skill software installed and not Armoury crate, during those hours the lights never froze, so I think the culript here is Armoury crate. 

Do note that I tried also for several hours to control the lights with only Armoury crate installed in the pc and the lights still froze. It only got better around yesterday evening when I did the following.

  1. Uninstall Armoury crate with it's uninstaller
  2. Reboot
  3. Uninstall the G skill software with RevoUninstaller getting rid of all it's related files
  4. Reboot
  5. Install G skill software and set up the lights from there (It's set up to not launch during the boot of the pc)
  6. Reboot
  7. Now here starts the 4-5 hours window where Armoury crate repeatedly had errors during the installation process (error 502), for a total of 4 Installation tries(had a pause in between them,and every failed try had the uninstall tool used on it before rebooting and reattempting the next one) The lights of the RAM never froze and remained on the configuration I gave it in the G skill software
  8. Install Armoury crate
  9. Reboot
  10. Set up a new Auracreator config, now the lights are working flawlessly
  11. Reboot
  12. From 11 PM to 3 AM no issues
  13. Shutdown
  14. Boot the PC at 9 AM today, no issues here either
  15. Reboot the PC at 7:30PM due to a windows update
  16. Ram Froze up after 40 seconds of use

I'm attaching a log I made before this cycle of operations, it captured a moment where the RAM lights froze up, maybe it will help, maybe it will not...I hope It does since I spent more money to have all compatible RGB and I'd like to have it working as advertised
Small update: It's much rarer but sometime instead of only the ram, all the RGB in the system freezes, when that happens Auracreator displays the behaviour shown in the image on the following reply


Level 9

Also this just happened: Mouse got disconnected and reconnected(Probably broken cable or smth) and it killed off all the rgb in my system freezing it straight up. Look at this, Aura creator can't even recognize them anymore

Also after the last reboot  one ram is frozen, the other is frozen from the middle down, I can see the top switching from white-green-green-white as set up by aura creator.


"No available devices", if this happens Armourycrate will sometimes display everything as connected and synced or just load in a loop the aurasync section


Level 9

I see you are using the G.Skill Software. I am not using any. Is the software for clocks and data transfer enhancements or is it for the lighting only? If so, uninstall that software and see if it freezes...maybe that is the problem. 

>"Do note that I tried also for several hours to control the lights with only Armoury crate installed in the pc and the lights still froze"<

It's the software made for controlling only the lights on the ram sticks. I already tried all the possible combinations. 

  1. only gskill software:no issue
  2. only armoury crate:issue
  3. install first crate THEN gskill:issue
  4. install first gskill THEN crate:issue

So far the only constant is that the problem presentes itself only when Armoury crate is installed in the system

But just to be sure I uninstalled the gskill software. They don't even start up now, just stay white and that's it

So you took out the G.Skill software but did you use the armoury crate? the ram wont work itself. The only software for the RGB is Armoury Crate.  Everything else is out.


Yes of course i'm using AC, how else would I control my whole pc? Eerything but psu,case and ram is ASUS branded

I don't know what to say. On your other post, someone said to uninstall the Framework software until the next update, but I don't have a problem with that. I think trying your RAM in a friends system to see if it freezes would be your best choice. If it turns out to be the RAM, G.Skill is Lifetime Warranty

What framework are you referring to? the asus one? Is there some sort of guide to know what do I have to delete? Or is it just a matter of uninstalling AC and then reinstalling it without updating it?


Check your other post. You have to uninstall AC and reinstall without net framework