Showing results for 
Search instead for 
Did you mean: 

Firmware Updates Failing in Armoury Crate - ROG Falchion Wireless Keyboard

Level 9
Have brand new setup: ROG Maximus Extreme Z690 MB, ROG Strix 3090 Ti LC OC AIO, ROG Gladius II wireless mouse and ROG Falchion wireless keyboard (on Win 11 Pro, Intel i9 12900 KS [cooled by Corsair H170i AIO with iCue LED/fan controller software], Asus Thor 1200-P PS.

I'm pulling my hair out trying to resolve mouse & keyboard issues. Current firmware for both is from Sept. 9.

While building PC, I ordered the mouse & keyboard. Keyboard was installed first and has never worked properly. I have not been able to update firmware on the keyboard even though Armoury Crate recognizes an update is available. The keyboard has never been useable while connected by cable. It seems to charge as I can use it for days on end after leaving it plugged in overnight but I can't use it as a keyboard while it's connected via USB (over every available USB port - motherboard or case - original cable or not - it is dark & dead - unresponsive when connected via USB). The battery indicator lights have always been indicating at the very low end of out of juice. Never higher. Armoury Crate only ever showed battery level at 20%. Permanently. Never changed regardless of charge state. The only thing Armoury Crate can do is change the keyboard lighting colors. Have never tried Aura or anything beyond basic key color and brightness. Don't want it.

The mouse was delayed in shipping but when it arrived, it worked flawlessly by itself and within Armoury Crate even though keyboard was still flaky. Then the mouse wanted a firmware update too and I can no longer update even that. It works just fine but is dark. No LEDs illuminated at all.

Have installed and uninstalled Armoury Crate with Uninstall Tool 3 or 4 times. Have read so many Armoury Crate fix threads that my head is spinning.

While building the PC (a 2 month process) and then finally booting up to this scenario (rinse, repeat, rage) the 30 day Best Buy keyboard return window has closed. They told me to, well, go away.

So here I sit. In all my searching and troubleshooting I have not located a fix.

Armoury Crate is currently uninstalled but there is a lot of stuff left in the registry. Attaching pic of the bulk of it but there are 6 or 10 individual registry entries under various Class addresses.

Armoury Crate install initially installed through BIOS option; auto-install now disabled in BIOS after last uninstall with Uninstall Tool.

I see a lot of Armoury Crate chatter here and out on the interwebs but have not seen a definitive fix that applies here.

Any help appreciated. Registry pic attached.

Edit: forgot this one from HKEY_USER

Hello Greg F

Make sure you have the cable connected to your ROG Falchion and a usb port on your pc, connect the wireless dongle to a usb port, set the ROG Falchion wireless switch to ON.

Same thing for your ROG Gladius II.

Connect the cable to your mouse and a usb port, connect the wireless dongle and set the wireless switch to 2.4GHz wireless mode.

Then try the updates in Armoury Crate.

If you've made any changes to the registry you might want to do a fresh windows reinstall.

The latest version of Armoury Crate is

Click the pic to make it bigger.


Nate152 wrote:
Hello Greg F

Thanks Nate: I saw your previous responses to users and have followed all the steps several times without success.

Most recent uninstall tool & reinstall produced Unexpected Error initially and directed to Uninstall Tool. Completed that w restart.

Mouse issues self rectified with Crate reinstall. Keyboard did not.

While attempting to regain full functionality of keyboard I encountered 2 problems:
1) Certain Armoury Crate features may be disabled because some Asus Application Services are not running. Code 2005
2) Same message with Code 2006

Keyboard Firmware 32.72.02 22/09/06

In Windows Device Manager I have odd looking entries and am considering uninstalling hardware from there and then reinstalling Falchion first in wired mode IF I CAN GET WINDOWS TO RECOGNIZE IT.

No registry changes made. Period. Screeners for info only.

******My currently installed version of Armoury Crate is I believe that COULD be the version from BIOS auto-install but have uninstalled & reinstalled so many times I'm just not sure.

When I go to Armoury Crate Support at it provides Version 3.2.3 as most current version for Win 11/64.

Do you know where I can find 5.3.2 ?

Attaching Hardware & Asus AC DL screeners. Appreciate your input.

In Armoury Crate my notifications indicate both Falchion keyboard AND Gladius mouse require firmware updates. Leaving the keyboard for now but when I go to update the mouse ArmCrate refreshes the hardware list & the mouse disappears from my hardware list.


Thank you

Actually, all looks good in your device manager, mine looks similar.


As you did, install Armoury Crate version, they delayed version so for now you have the latest version of Armoury Crate.

You mention your ROG Falchion doesn't work with the cable, this could be why it's not updating. Would you by chance have another cable to test with?

If you still get the 2005 - 2006 error, you will likely have to do a windows reinstall. I encountered the 2005 error once with the ROG Falchion, the uninstall tool didn't fix this particular error, a windows reinstall fixed it.

I had lengthy partial reply written and it just evaporated as I tried to post it. I am having a time....

Regardless, we can consider this RESOLVED for now. I have everything working as it should with a very minor exception. I am happy.

I have pages of detailed scrawl that I will share when I get a minute but will have to decipher and summarize.

Thank you so much for sticking with this thread. You are an asset to the community and I really appreciate your assistance.

I am now going to try and enjoy the remainder of the weekend and I hope you do too.

Cheers to you Nate!

You're welcome,

This is sounding better, is your ROG Falchion working with the cable?

I'd be interested to know the minor exception.

Nate152 wrote:
You're welcome,

I really thought I had this cased last weekend. I did a painstaking step-by-step uninstall/re-install of Crate. Things went really well for a few hours. Mouse did everything I needed it to do. After a few hours, the mouse operated with extreme lag. It was unusable. Keyboard was fine.

I won't elaborate on my Crate reinstall details because ultimately they were not successful and they really weren't any different than what others have tried. Gladius firmware is now 2.36.40 which I believe is current. I think Falchion is 32.72.02.

In the end I wiped my machine clean and did a complete Win 11 reinstall from the ground up without Armoury Crate. Rebuild was completed entirely without Asus peripherals connected via USB.

The Gladius & Falchion are working well enough now without Armoury Crate, more or less. I had not assigned any hotkeys to kb through AC so there are none to lose. The battery level on Falchion shows full charge and the volume slider works. I'll assume the battery charge level will work as intended. The only real difference is in the mouse. I had programmed the button behind scroll wheel to 'double click' which I really liked. Also, mouse RGB is now not my preferred scheme (it's now purple fade). It used to reveal battery level.

My last RGB fan selection through Arm Crate was white and that is how it continues to stay. I can control fan speeds through BIOS with no mapping options. I will just leave the RGB white and hope it doesn't change to something ugly. The addressable RGB on mo-board is some alternating neon combo. Yuck.

I tried the mouse with Bluetooth but my Bluetooth on the ROG Max Z690 Ext is flaky too. Other BT devices have failed and it's just not reliable. I'm just going to accept that my pricey new machine has some serious flaws. I've lost so much time and productivity trying to sort this out and now just need to get back to work.

Thanks for the help and advice. Will advise if anything changes.

Edit: Seconds after posting mouse reverted to slow motion again. Maxed the settings speed and it will be barely tolerable for productivity. Gaming? Not a chance. And Bluetooth peripherals from other manufacturers are not an option due to flaky BT. I will probably spend more money at some point trying to fix that with more hardware work-arounds. So disappointing. Never thought I'd spend this much money on a PC for so much grief.