cancel
Showing results for 
Search instead for 
Did you mean: 

Faulting application AacAmbientLighting.exe and Armoury Crate v5.7.9

EdwardQ
Level 10

I am a long time Asus lover, but my patience is severely being tested with Armoury Crate - after issues with earlier versions of Armoury Crate there was a period of stability, and with the latest version of Armoury Crate (v5.7.9.0) I am now getting intermittent crashes with the AacAmbientLighting.exe component on a Z13.

Asus - please bug test your applications!!!!!!!!!!! and better still - ASK users before updating their version of the application!!!!!

Error below - 

Faulting application name: AacAmbientLighting.exe, version: 1.2.0.0, time stamp: 0x64b073ea
Faulting module name: KERNELBASE.dll, version: 10.0.22621.2792, time stamp: 0x3091b6fb
Exception code: 0xe0434352
Fault offset: 0x000000000006567c
Faulting process ID: 0x0x2BB4
Faulting application start time: 0x0x1DA307AFE8E4158
Faulting application path: C:\Program Files\ASUS\AacAmbientHal\AacAmbientLighting.exe
Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
Report ID: 3aa451df-58da-48b5-a83c-ee1c661e7a5e
Faulting package full name: ASUSAmbientHAL64_1.0.0.2_neutral__gsg7p0crx7n6a
Faulting package-relative application ID: ASUSAmbientHAL64

67,696 Views
1 ACCEPTED SOLUTION

Accepted Solutions

Currently, the temporary solution is to uninstall and install Armoury Crate. 

MasterC_0-1703668689507.png

The schedule for the update has been pulled in again to Dec. 29th. If you can't wait to try the update before testing is complete, here is the download. Please install and reboot, then install any updates available in Armoury Crate.

_____________________________________________________________
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin

View solution in original post

187 REPLIES 187

alltdl
Level 9

I am also experiencing intermittent crashes on a Z790-A.  Very frustrating! I am also seeing another error (posted below). 

In addition, my machine is giving kernel errors when waking up from sleep, not sure if related but issues started after updating to v5.7.9

Application: AacAmbientLighting.exe
CoreCLR Version: 6.0.2523.51912
.NET Version: 6.0.25
Description: The process was terminated due to an unhandled exception.
Exception Info: System.Net.Sockets.SocketException (10048): Only one usage of each socket address (protocol/network address/port) is normally permitted.
at System.Net.Sockets.Socket.UpdateStatusAfterSocketErrorAndThrowException(SocketError error, String callerName)
at System.Net.Sockets.Socket.DoBind(EndPoint endPointSnapshot, SocketAddress socketAddress)
at System.Net.Sockets.Socket.Bind(EndPoint localEP)
at AacAmbientLighting.Program.Main()

alltdl
Level 9

I went ahead and used the Armory Crate Uninstall tool.  My kernel-power issues have gone away. 
I would like to use Armory Crate. However, I am going to hold off until the issues with v5.7.9 have been resolved.

To clarify my previous post, I have the same error as the OP, plus I found the unhandled exception error.

Thanks for info @alltdl - Can I ask where you downloaded the uninstall tool? Is there a new version? 
Did you uninstall the old version first using Microsoft Store/"Program & Features" and then run the uninstall tool?
Is there a new 5.7.9 install binary?

I downloaded the uninstall tool from here: https://www.asus.com/us/motherboards-components/motherboards/prime/prime-z790-a-wifi/helpdesk_downlo... 

Scroll down to the Utilities: Armoury Crate >>> See All Downloads

msedge_Wv9C8hDqJ9.png

Just run this tool, you do not need to uninstall anything from the MS Store or Add Remove Programs.

Thanks @alltdl This worked - So I have a Z13 and actually removed the application via right click/Uninstall on the Start Menu and rebooted.  The GPU switch tray icon disappeared and I reinstalled and it worked again (and the GPU app re-appeared) - I didn't have to run the uninstall tool at all.

Awesome! 

Did you reinstall Crate to v5.7.9? Did the AacAmbientLighting.exe errors go away? 

Once you opt to do a re-install, it will always install the new version - you can't install the old version of the app.

So far (touch wood) I haven't had any issue with any part of the app crashing

Interesting. Maybe it's an issue with upgrading an older version of Crate?

I uninstalled Crate, but I'll try installing when I get home.