cancel
Showing results for 
Search instead for 
Did you mean: 

Fan Xpert does't work in Armoury Crate

emkdrl07
Level 10
Hey, I cannot run Fan Xpert in Armory Crate. So many times i have uninstalled AC with Armoury Crate Uninstall Tool then installed but not changed. it's really annoying i would appreciate it if you could help me.

Item Version
---- -------
Armoury Crate UWP App 5.3.4.0
ROG Live Service 1.6.4.0
Aura Service (Lighting Service) 3.05.78
Armoury Crate lite service 5.3.3
Aura Wallpaper Service Yüklü değil
ASUS AIOFan HAL 1.1.50.0
ASUS AURA Extension Card HAL 1.1.0.18
ASUS AURA Motherboard HAL 1.3.9.1
ASUS Keyboard HAL 1.2.23.0
ASUS Mouse HAL 1.2.0.58
ASUS MousePad HAL 1.0.3.5
AacVGA 0.0.5.8
KingstonDram 1.1.18
AURA DRAM Component 1.1.23
ENE RGB HAL 1.1.40.3
ENE_EHD_M2_HAL 1.0.10.1
PHISON HAL 1.0.9.0
Patriot Viper DRAM RGB 1.0.9.5
Patriot Viper M2 SSD RGB 1.1.0.2
Universal Holtek RGB DRAM 1.0.0.4
WD_BLACK AN1500 1.0.14.0
30,346 Views
85 REPLIES 85

Jimbo93 wrote:
Now in order for it to work we need to satisfy 2 conditions. 1) Armoury Crate shouyld be removed by the AC uninstall tool. 2) We need to make sure you don't have a service left over called Armoury Live Update which gets installed by windows update along with Aura device drivers.

So go ahead and run the Armoury Crate uninstall tool.

Then reboot and have a look for a service called Armoury live update. You will have to open services or computer management->services and see. If it is there then the next step is to get and run the driver store explorer so we can see what aura device drivers we need to remove. When the the aura device drivers are removed with the driver store explorer, the Armoury Live update is automaticall removed with them. The exact steps I use to do this:

Pause window update.
Run driver store explorer as admin.
Select the ROG/AsusTek drivers for mouse and keyboard and then hit the force delete button.
Reboot.
Verify that Armoury Live update is gone. If it is not there must be another ROG device driver to delete.
If the Service was removed then you can run the AI Suite 3 Cleaner as admin and restart.
After that the only Asus service that should be left and running is the AsusCertService. We need to verify that condition before going to the next step. I am including a picture of driver store explorer and my ROG device drivers as an example, yours will likely be slightly different.
Link to download driver store explorer. https://github.com/lostindark/DriverStoreExplorer/releases/latest

97366


Thank you for helping me. When i available i am going to do what you say and let you know.

Good Lord. How about Asus just fix the dam problem. We spend $500 - $700 on these Asus motherboards, we shouldn't have to deal with these ridiculous cooling problems because they cant get Fan expert(Asus software) working properly in Armor Crate(Asus software) on a Asus motherboard?

I would like to see them remove Fan Expert from Armor Crate and  just get Fan Expert working on its own. I don't want to even Run Armor Crate. I suspect Asus has some control issues.

emkdrl07
Level 10
i did what you said all things. But never changed still does not work. I've included the ASUS programs below that work after doing what you said.97367

emkdrl07 wrote:
i did what you said all things. But never changed still does not work. I've included the ASUS programs below that work after doing what you said.97367


We left off at uninstalling AC and running the AI cleaner.

AsusFanControlService.exe and atkexComSvc.exe are not running (good). Did you already reinstall something? I thought we would do a couple more things before that. If you open Windows Settings->Apps->Installed Apps and search for Asus, what Asus programs are still listed as installed? This is going to be a step by step process if we want to get it right.

Jimbo93 wrote:
We left off at uninstalling AC and running the AI cleaner.

AsusFanControlService.exe and atkexComSvc.exe are not running (good). Did you already reinstall something? I thought we would do a couple more things before that. If you open Windows Settings->Apps->Installed Apps and search for Asus, what Asus programs are still listed as installed? This is going to be a step by step process if we want to get it right.


yes I have reinstalled Armory Crate, let me do again the deleted steps and let you know.

emkdrl07
Level 10
I did all the deletions again.

The only one ASUS driver that appears in the Driver Store Explorer after the deletion process is shown below.
97369

ASUS applications running inside windows settings>apps after deletion; AsusFCNotification, GameFirst VI(I haven't uninstalled this one anyway), Sonic radar 3(I haven't uninstalled this one anyway) and Sonic Studio 3(I haven't uninstalled this one anyway)

What next, i am not going to install again AC and waiting for your reply.

emkdrl07 wrote:
I did all the deletions again.

The ASUS driver that appears in the Driver Store Explorer after the deletion process is shown below.
97369

ASUS applications running inside windows settings>apps after deletion; AsusFCNotification, GameFirst VI(I haven't uninstalled this one anyway), Sonic radar 3(I haven't uninstalled this one anyway) and Sonic Studio 3(I haven't uninstalled this one anyway)

What next, i am not going to install again AC and waiting for your reply.


It would be a good idea to just verify that AsusCertService is running properly. I am attaching 2 pictures. One picture of the Windows Event Log - Application Log - In the first few log entries on system start the AsusCertService should log "The operation completed successfully". And task manger should show the process running. And there should be no error in the event logs associated with AsusCertService. Pictures to follow in a few.

97370

See the attached picture in my previous post. If AsusCertService is running ok. Then the next step would be to uninstall GeForce Experience (If you have it only of course). Then to toggle the windows features .NET 3.5 and .NET 4.8 advanced off and back on. Then to reboot and run automatic system maintenance uninterrupted. Takes max of 30 minutes probably. Run the Armoury Crate installer a couple of times in row without uninstalling. If thats not successful. You would have to repeat the original cleaning steps. And thry installing AI Suite 3 itself and see if it provides an AsusFanController.exe. If it does, and it runs without causing Asus crashing programs, then you should be able to install Armoury Crate and have fan control. But not having your system to play with makes exact diagnosis difficult.

emkdrl07
Level 10
yes AsusCertService is running ok.
97371
97372
97373

I will do what other you said on tomorrow and let you know.

There are a few things I want to clarify.
1. Should I install AI Suite 3 or Armory Crate first?
2. When you say "original cleaning steps", you mean uninstalling with AC uninstall tool only, right?

emkdrl07 wrote:
yes AsusCertService is running ok.
97371
97372
97373

I will do what other you said on tomorrow and let you know.

There are a few things I want to clarify.
1. Should I install AI Suite 3 or Armory Crate first?
2. When you say "original cleaning steps", you mean uninstalling with AC uninstall tool only, right?


On my system the 2 programs share some fancontrol components. I can install either one first. But on a system that has had problems like yours in, if we want to get it working we have to experiment by installing differently one before the other. In between those experiments follow the AI suite 3 full cleanup procedure which I just made you do. That means AC uninstaller, followed by special AI SUite 3 Cleaner steps.