cancel
Showing results for 
Search instead for 
Did you mean: 

Error with the device page - error 2006

RiskyFuture
Level 7
Hi all getting the following error on Armory crate, has anyone a fix for this it just keeps going round in a loop when I click ok. I'm on windows 11 pro as advised by a moderator.
91960
28,184 Views
39 REPLIES 39

eduaf1
Level 7
HI everyone !
I had this problem...
and resolve woth ccleaner free edition.....

9656396563

Remigz
Level 7
I also have the same issue with B550M-Plus motherboard but i don't, tried reinstalling a lot and didn't work

cekeu
Level 12
I haven't had any problems with AC for a long time. But I have experienced that by reinstalling ArmoryCrateInstallTool over the existing installation and then restarting the pc then it fixes the malfunctions that we encounter.
With AC I manage the colors of my rog motherboard, my rog graphics card, my gskill memories except that gskill is not detected if I use aura creator, in this case I use g.skill trident z lighting control.
And AC also allows me to manage the light of the keyboard and mouse rog and to configure their performance.
I don't use any background registry cleaners and cleaners or even the ones that come with 3rd party antiviruses, I like windows security, it's more than enough on a valid windows license. I like the tools built into windows for system maintenance

Chibi
Level 7

Hey everyone, 

i have a G15CE-B9 build. I swapped the CPU fan with the Vetroo V5, swapped the stock exhaust fan, added another exhaust and intake fan. 

My problem is that Armoury Crate doesn’t recognize my MB. I’ve uninstalled with the uninstall tool and reinstalled, I’ve installed over the installed Armoury Crate without uninstalling first, I’ve clean installed Windows 11. All to no avail. 

I’ve already made sure all updates to Armoury Crate were made, all Windows 11 updates installed, updated BIOS to 216. I don’t know what else to do. Any help out there?

far2005
Level 7

To those who are having this problem:

1) shutdown

2) remove the bios battery and then re-insert ( don't forget to disconnect all the cables )

3) if you're using OC, do not apply them now, keep it in stock, go too boot option and disable armoury create

4) boot to windows, install AI suit using armory, then restart, then unintall AI suit, armory create and then reboot

5) reinstall armory create, do not go into fan xpert, reboot to bios, enable armory create install, apply your OC

6) boot to windows, and now you should have fan xpert working again

 

VikingTechno
Level 7

I found a solution that worked for me! Make sure Armoury Crate is fully shutdown, then go to " C:\Program Files (x86)\ASUS\AsusFanControlService\2.03.26 " and run the following in this order:

AsusFanControlService.exe

FanSetup.exe

setup.exe

Afterwards launch Armoury Crate and Fan Xpert should work again. I hope this helps some people!

 

Tarsinion
Level 7

Hi, I have TUF GAMING WIRELLES and after updating the driver in armory crate from 19.6.2023 I started to get error 2006. It also stopped showing the battery status notification.

Tarsinion
Level 7

Hi, I have TUF GAMING WIRELLES and after updating the driver in armory crate from 19.6.2023 I started to get error 2006. It also stopped showing the battery status notification. Pls, fix the error

lubor_vrabel
Level 7

I had this error 2006 with my ASUS Croshair VII + Asus Falchion Keybord
Maybe this will help somebody.

I did uninstall all Asus related apps from classic control  panel.
I installed all the apps again, no change.
I did uninstall all Asus related apps from classic control  panel again just to realize that they are still in modern W11 UI settings - apps
So I uninstalled all ASUS apps from both places, I mean all of them...
Reinstalled the latest Armory Crate and the error went away for the board and the keyboard on wired connection.
On wireless the keyboard still had the error also it did not sync the RGB profile.
I have a Dell monitor with KVM switch where the asus falchion keybord wireless USB was plugged in.

Finally I plugged the Wireless USB directly to my computer and all problems disappeared  and the Armory Crate app also much more responsive, I don't know what is with my KVM, but all other devices work fine.

 

gtxplus1
Level 7

i've got few times "error with the device page" when tried to open ROG Ryugin II page in Armory Crate. windows 11 licenced

found a solution.

1] uninstalled all asus software,

2] then deleted all asus software in CCleaner (probably this is not needed)

3] booted windows in safe mode, deleted full Asus folder in hidden folder C:\ProgramData and C:\Program Files (x86)

after that installed again Asus Armory Crate and now i can open Ryujin II page.

dont thank me, just give 15 euro. cheers