Showing results for 
Search instead for 
Did you mean: 

Error with the device page - error 2006

Level 7
Hi all getting the following error on Armory crate, has anyone a fix for this it just keeps going round in a loop when I click ok. I'm on windows 11 pro as advised by a moderator.

Level 7
HI everyone !
I had this problem...
and resolve woth ccleaner free edition.....


Level 7
I also have the same issue with B550M-Plus motherboard but i don't, tried reinstalling a lot and didn't work

Level 10
I haven't had any problems with AC for a long time. But I have experienced that by reinstalling ArmoryCrateInstallTool over the existing installation and then restarting the pc then it fixes the malfunctions that we encounter.
With AC I manage the colors of my rog motherboard, my rog graphics card, my gskill memories except that gskill is not detected if I use aura creator, in this case I use g.skill trident z lighting control.
And AC also allows me to manage the light of the keyboard and mouse rog and to configure their performance.
I don't use any background registry cleaners and cleaners or even the ones that come with 3rd party antiviruses, I like windows security, it's more than enough on a valid windows license. I like the tools built into windows for system maintenance

Level 7

Hey everyone, 

i have a G15CE-B9 build. I swapped the CPU fan with the Vetroo V5, swapped the stock exhaust fan, added another exhaust and intake fan. 

My problem is that Armoury Crate doesn’t recognize my MB. I’ve uninstalled with the uninstall tool and reinstalled, I’ve installed over the installed Armoury Crate without uninstalling first, I’ve clean installed Windows 11. All to no avail. 

I’ve already made sure all updates to Armoury Crate were made, all Windows 11 updates installed, updated BIOS to 216. I don’t know what else to do. Any help out there?

Level 7

To those who are having this problem:

1) shutdown

2) remove the bios battery and then re-insert ( don't forget to disconnect all the cables )

3) if you're using OC, do not apply them now, keep it in stock, go too boot option and disable armoury create

4) boot to windows, install AI suit using armory, then restart, then unintall AI suit, armory create and then reboot

5) reinstall armory create, do not go into fan xpert, reboot to bios, enable armory create install, apply your OC

6) boot to windows, and now you should have fan xpert working again


Level 1

I found a solution that worked for me! Make sure Armoury Crate is fully shutdown, then go to " C:\Program Files (x86)\ASUS\AsusFanControlService\2.03.26 " and run the following in this order:




Afterwards launch Armoury Crate and Fan Xpert should work again. I hope this helps some people!