cancel
Showing results for 
Search instead for 
Did you mean: 

Error code 502 with new Armoury Crate update!

DariusDavedane
Level 9
I copied the text from here: https://rog.asus.com/forum/showthread.php?130014-Error-code-502-with-new-Armoury-Crate-update!

Somebody moved my post there, but I don't have Zephyrus laptop, I have a desktop, so, THIS IS NOT A LAPTOP RELATED ISSUE.


Dear all and ASUS!

I am getting 502 error code when I forced to install your software. And I am not the only one, more and more people complaining about this error.

I tried everything, except Win reinstall, what I don't want to do.

I tried your uninstaller...no change.
Several reboots, switching off antivirus, runing everything in admin mode...no change.
Every driver/software is up to date and legal on my computer.

Please, if anybody knows the solution, (or an alternative software to replace this), don't hesitate to provide the information.

Thank you for your help!
12,011 Views
41 REPLIES 41

DariusDavedane
Level 9
Picture of the error:

Same issue here.

I think that I've found part of the issue.

Can you confirm if yes or no, you can see the lightning service running inside Windows? It seems to be the culprit to me.

Me and my friend who just bought a new tuf series laptop facing the same issue. Tried everything from resetting bios to uninstall reinstall the ac using tool, but didnt work for us.
I am currently using ASus tuf F15 gaming laptop and this issue is not specifically spread amongst rog desktop or laptops but also affected TUf series motherboards and laptops too.
This issue happened when there was an update in my AC and when i tried to update it bOOm this happened , This is not hardware or fault issue it is purely software issue.

kahatanna7
Level 8
502 is a bad gateway server error. This means there is nothing wrong with your laptops, you just have to wait until ASUS fix their servers

kahatanna7 wrote:
502 is a bad gateway server error. This means there is nothing wrong with your laptops, you just have to wait until ASUS fix their servers


I may be wrong but my guess is that this error we keep on having is not an HTTP 502 error, it's an error thrown by the installer that has the same number. I hope that Asus would have solve a simple Web Server issue faster than a week

The problem is certainly not our laptop but the buggy software update release by Asus 😉

MasterC
Community Admin
Community Admin
Please check inbox, test version provided.

DariusDavedane wrote:
I copied the text from here: https://rog.asus.com/forum/showthread.php?130014-Error-code-502-with-new-Armoury-Crate-update!

Somebody moved my post there, but I don't have Zephyrus laptop, I have a desktop, so, THIS IS NOT A LAPTOP RELATED ISSUE.


Dear all and ASUS!

I am getting 502 error code when I forced to install your software. And I am not the only one, more and more people complaining about this error.

I tried everything, except Win reinstall, what I don't want to do.

I tried your uninstaller...no change.
Several reboots, switching off antivirus, runing everything in admin mode...no change.
Every driver/software is up to date and legal on my computer.

Please, if anybody knows the solution, (or an alternative software to replace this), don't hesitate to provide the information.

Thank you for your help!
_____________________________________________________________
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin

kahatanna7
Level 8
DariusDavedane wrote:
I copied the text from here: https://rog.asus.com/forum/showthread.php?130014-Error-code-502-with-new-Armoury-Crate-update!

Somebody moved my post there, but I don't have Zephyrus laptop, I have a desktop, so, THIS IS NOT A LAPTOP RELATED ISSUE.


Dear all and ASUS!

I am getting 502 error code when I forced to install your software. And I am not the only one, more and more people complaining about this error.

I tried everything, except Win reinstall, what I don't want to do.

I tried your uninstaller...no change.
Several reboots, switching off antivirus, runing everything in admin mode...no change.
Every driver/software is up to date and legal on my computer.

Please, if anybody knows the solution, (or an alternative software to replace this), don't hesitate to provide the information.

Thank you for your help!


I've had the same issue. Make sure you download and install ASUSSystemControlInterface Z_V1.1.4.0 prior to installing Armory Crate

kahatanna7 wrote:
I've had the same issue. Make sure you download and install ASUSSystemControlInterface Z_V1.1.4.0 prior to installing Armory Crate


I have the 3.1.4.0 ASUS System Control Interface v3 driver (which is the latest version) and i'm still getting the 502 error when updating Armory crate.

I had this problem yesterday, so I uninstalled all the software with the official ARMORY uninstaller. Off, after that I rather have the problem "no internet" which means nothing to me since I am connected.
I opened a new post for this, but I think it's related to the same problem as yours; whether it is no internet to install or to update seeing the error code 502.

On the other hand, I don't have the ASUS System Control Interface V3 in my pilot peripherals. I can't download it from the store either.
And, reading the manual here:
https://www.asus.com/support/FAQ/1039718#Win11_A3

I see that I can not do anything, I do not know where to download it.
I'm on desktop, maybe it's only for laptop. It's true ?