cancel
Showing results for 
Search instead for 
Did you mean: 

Error code 502 with new Armoury Crate update!

DariusDavedane
Level 9
I copied the text from here: https://rog.asus.com/forum/showthread.php?130014-Error-code-502-with-new-Armoury-Crate-update!

Somebody moved my post there, but I don't have Zephyrus laptop, I have a desktop, so, THIS IS NOT A LAPTOP RELATED ISSUE.


Dear all and ASUS!

I am getting 502 error code when I forced to install your software. And I am not the only one, more and more people complaining about this error.

I tried everything, except Win reinstall, what I don't want to do.

I tried your uninstaller...no change.
Several reboots, switching off antivirus, runing everything in admin mode...no change.
Every driver/software is up to date and legal on my computer.

Please, if anybody knows the solution, (or an alternative software to replace this), don't hesitate to provide the information.

Thank you for your help!
11,718 Views
41 REPLIES 41

I found the solution to this issue which worked for me perfectly .. Go to BIOS and disable armoury crate interface (make it disabled).. then restart.. open Armoury Crate and let it install (will give error again).. now restart and enable the armoury crate interface in BIOS.. boot and enjoy the new armoury crate!!

kingslaver wrote:
I found the solution to this issue which worked for me perfectly .. Go to BIOS and disable armoury crate interface (make it disabled).. then restart.. open Armoury Crate and let it install (will give error again).. now restart and enable the armoury crate interface in BIOS.. boot and enjoy the new armoury crate!!


Followed each step but doesnt work for me.

Random_
Level 7
this is the log link, Its been a months now still there is not solution
been using the old AC version found from the post in reddit installation was in german.

https://drive.google.com/file/d/1vTh_ae4_L6svm7qCiNYYKJ3Nbpop6tuC/view?usp=sharing
https://drive.google.com/file/d/1ULeOUgWx1bbEVl7SjKNTQef726-ES-vI/view?usp=sharing

94689

ellie11
Level 7
Hi,

I'm having Asus Tuf Gaming F15 2021. I formatted and freshly installed windows 11. Whenever I tried to install Armoury crate it showing 502 error. I searched and found install desktop runtime and try to install armoury crate again. But it seems still showing the 502 error. i checked the logs and i found

[8/23/2022 0:06:15 13876] ACSetup: Init
[8/23/2022 0:06:15 13876] ACSetup: Listen
[8/23/2022 0:06:15 13876] ACSetup: Listen UWPDefaultPort: 23210
[8/23/2022 0:06:15 13876] ACSetup: Listen end
[8/23/2022 0:06:15 13876] ACSetup: Init end
[8/23/2022 0:06:16 13876] ACSetup: listener_ConnectionReceived
[8/23/2022 0:06:17 13876] ACSetup: UWP Connect success.
[8/23/2022 0:06:17 13876] ACSetup: StartReceiveTask
[8/23/2022 0:06:17 13876] ACSetup: StartReceiveTask end
[8/23/2022 0:06:17 13876] ACSetup: listener_ConnectionReceived end
[8/23/2022 0:06:17 13876] ACSetup: StartReceiveInternal
[8/23/2022 0:06:17 13876] ACSetup: Receive data
[8/23/2022 0:06:17 13876] ACSetup: ProcessStreamPacket
[8/23/2022 0:06:17 13876] ACSetup: ProcessStreamPacket FirstLaunch
[8/23/2022 0:06:17 13876] ACSetup: ProcessStreamPacket FirstLaunch Version: 5.2.12.0
[8/23/2022 0:06:17 13876] ACSetup: First Launch
[8/23/2022 0:06:20 13876] ACSetup: Connect2RLS
[8/23/2022 0:06:20 13876] ACSetup: GetConnectionPort
[8/23/2022 0:06:20 13876] ACSetup: GetConnectionPort end port: 22112
[8/23/2022 0:06:20 13876] ACSetup: Try to connect RLS on port 22112
[8/23/2022 0:06:20 13876] ACSetup: ProcessStreamPacket end
[8/23/2022 0:06:22 13876] ACSetup: Connect RLS Fail
[8/23/2022 0:06:27 13876] ACSetup: Retry connect RLS
[8/23/2022 0:06:27 13876] ACSetup: Connect2RLS
[8/23/2022 0:06:27 13876] ACSetup: GetConnectionPort
[8/23/2022 0:06:27 13876] ACSetup: GetConnectionPort end port: 22112
[8/23/2022 0:06:27 13876] ACSetup: Try to connect RLS on port 22112
[8/23/2022 0:06:29 13876] ACSetup: Connect RLS Fail
[8/23/2022 0:06:34 13876] ACSetup: Retry connect RLS
[8/23/2022 0:06:34 13876] ACSetup: Connect2RLS
[8/23/2022 0:06:34 13876] ACSetup: GetConnectionPort
[8/23/2022 0:06:34 13876] ACSetup: GetConnectionPort end port: 22112
[8/23/2022 0:06:34 13876] ACSetup: Try to connect RLS on port 22112
[8/23/2022 0:06:36 13876] ACSetup: Connect RLS Fail
[8/23/2022 0:06:41 13876] ACSetup: Retry connect RLS
[8/23/2022 0:06:41 13876] ACSetup: Connect2RLS
[8/23/2022 0:06:41 13876] ACSetup: GetConnectionPort
[8/23/2022 0:06:41 13876] ACSetup: GetConnectionPort end port: 22112
[8/23/2022 0:06:41 13876] ACSetup: Try to connect RLS on port 22112
[8/23/2022 0:06:43 13876] ACSetup: Connect RLS Fail
[8/23/2022 0:06:47 13876] ACSetup: Receive data
[8/23/2022 0:06:47 13876] ACSetup: ProcessStreamPacket
[8/23/2022 0:06:47 13876] ACSetup: ProcessStreamPacket HeartBeat
[8/23/2022 0:06:47 13876] ACSetup: HeartBeat: _isRLSConnected == false
[8/23/2022 0:06:47 13876] ACSetup: ReturnResult2UWP command: HeartBeat result: Fail
[8/23/2022 0:06:47 13876] ACSetup: ReturnResult2UWP end
[8/23/2022 0:06:47 13876] ACSetup: ProcessStreamPacket end
[8/23/2022 0:06:48 13876] ACSetup: Retry connect RLS
[8/23/2022 0:06:48 13876] ACSetup: Connect2RLS
[8/23/2022 0:06:48 13876] ACSetup: GetConnectionPort
[8/23/2022 0:06:48 13876] ACSetup: GetConnectionPort end port: 22112
[8/23/2022 0:06:48 13876] ACSetup: Try to connect RLS on port 22112
[8/23/2022 0:06:50 13876] ACSetup: Connect RLS Fail
[8/23/2022 0:06:55 13876] ACSetup: Retry connect RLS
[8/23/2022 0:06:55 13876] ACSetup: Connect2RLS
[8/23/2022 0:06:55 13876] ACSetup: GetConnectionPort
[8/23/2022 0:06:55 13876] ACSetup: GetConnectionPort end port: 22112
[8/23/2022 0:06:55 13876] ACSetup: Try to connect RLS on port 22112
[8/23/2022 0:06:58 13876] ACSetup: Connect RLS Fail
[8/23/2022 0:07:03 13876] ACSetup: Retry connect RLS
[8/23/2022 0:07:03 13876] ACSetup: Connect2RLS
[8/23/2022 0:07:03 13876] ACSetup: GetConnectionPort
[8/23/2022 0:07:03 13876] ACSetup: GetConnectionPort end port: 22112
[8/23/2022 0:07:03 13876] ACSetup: Try to connect RLS on port 22112
[8/23/2022 0:07:05 13876] ACSetup: Connect RLS Fail
[8/23/2022 0:07:10 13876] ACSetup: Retry connect RLS
[8/23/2022 0:07:10 13876] ACSetup: Connect2RLS
[8/23/2022 0:07:10 13876] ACSetup: GetConnectionPort
[8/23/2022 0:07:10 13876] ACSetup: GetConnectionPort end port: 22112
[8/23/2022 0:07:10 13876] ACSetup: Try to connect RLS on port 22112
[8/23/2022 0:07:12 13876] ACSetup: Connect RLS Fail
[8/23/2022 0:07:17 13876] ACSetup: Receive data
[8/23/2022 0:07:17 13876] ACSetup: ProcessStreamPacket
[8/23/2022 0:07:17 13876] ACSetup: ProcessStreamPacket HeartBeat
[8/23/2022 0:07:17 13876] ACSetup: HeartBeat: _isRLSConnected == false
[8/23/2022 0:07:17 13876] ACSetup: ReturnResult2UWP command: HeartBeat result: Fail
[8/23/2022 0:07:17 13876] ACSetup: ReturnResult2UWP end
[8/23/2022 0:07:17 13876] ACSetup: ProcessStreamPacket end
[8/23/2022 0:07:17 13876] ACSetup: Retry connect RLS
[8/23/2022 0:07:17 13876] ACSetup: Connect2RLS
[8/23/2022 0:07:17 13876] ACSetup: GetConnectionPort
[8/23/2022 0:07:17 13876] ACSetup: GetConnectionPort end port: 22112
[8/23/2022 0:07:17 13876] ACSetup: Try to connect RLS on port 22112
[8/23/2022 0:07:19 13876] ACSetup: Connect RLS Fail
[8/23/2022 0:07:24 13876] ACSetup: Retry connect RLS
[8/23/2022 0:07:24 13876] ACSetup: Connect2RLS
[8/23/2022 0:07:24 13876] ACSetup: GetConnectionPort
[8/23/2022 0:07:24 13876] ACSetup: GetConnectionPort end port: 22112
[8/23/2022 0:07:24 13876] ACSetup: Try to connect RLS on port 22112
[8/23/2022 0:07:26 13876] ACSetup: Connect RLS Fail
[8/23/2022 0:07:31 13876] ACSetup: Retry connect RLS
[8/23/2022 0:07:31 13876] ACSetup: Connect2RLS
[8/23/2022 0:07:31 13876] ACSetup: GetConnectionPort
[8/23/2022 0:07:31 13876] ACSetup: GetConnectionPort end port: 22112
[8/23/2022 0:07:31 13876] ACSetup: Try to connect RLS on port 22112
[8/23/2022 0:07:33 13876] ACSetup: Connect RLS Fail
[8/23/2022 0:07:38 13876] ACSetup: Retry connect RLS
[8/23/2022 0:07:38 13876] ACSetup: Connect2RLS
[8/23/2022 0:07:38 13876] ACSetup: GetConnectionPort
[8/23/2022 0:07:38 13876] ACSetup: GetConnectionPort end port: 22112
[8/23/2022 0:07:38 13876] ACSetup: Try to connect RLS on port 22112
[8/23/2022 0:07:40 13876] ACSetup: Connect RLS Fail
[8/23/2022 0:07:45 13876] ACSetup: Retry connect RLS
[8/23/2022 0:07:45 13876] ACSetup: Connect2RLS
[8/23/2022 0:07:45 13876] ACSetup: GetConnectionPort
[8/23/2022 0:07:45 13876] ACSetup: GetConnectionPort end port: 22112
[8/23/2022 0:07:45 13876] ACSetup: Try to connect RLS on port 22112
[8/23/2022 0:07:47 13876] ACSetup: Receive data
[8/23/2022 0:07:47 13876] ACSetup: ProcessStreamPacket
[8/23/2022 0:07:47 13876] ACSetup: ProcessStreamPacket HeartBeat
[8/23/2022 0:07:47 13876] ACSetup: HeartBeat: _isRLSConnected == false
[8/23/2022 0:07:47 13876] ACSetup: ReturnResult2UWP command: HeartBeat result: Fail
[8/23/2022 0:07:47 13876] ACSetup: ReturnResult2UWP end
[8/23/2022 0:07:47 13876] ACSetup: ProcessStreamPacket end
[8/23/2022 0:07:47 13876] ACSetup: Connect RLS Fail
[8/23/2022 0:07:47 13876] ACSetup: Retry connect RLS Fail
[8/23/2022 0:07:47 13876] ACSetup: Connect2RLS end
[8/23/2022 0:07:47 13876] ACSetup: Connect2RLS end
[8/23/2022 0:07:47 13876] ACSetup: Connect2RLS end
[8/23/2022 0:07:47 13876] ACSetup: Connect2RLS end
[8/23/2022 0:07:47 13876] ACSetup: Connect2RLS end
[8/23/2022 0:07:47 13876] ACSetup: Connect2RLS end
[8/23/2022 0:07:47 13876] ACSetup: Connect2RLS end
[8/23/2022 0:07:47 13876] ACSetup: Connect2RLS end
[8/23/2022 0:07:47 13876] ACSetup: Connect2RLS end
[8/23/2022 0:07:47 13876] ACSetup: Connect2RLS end
[8/23/2022 0:07:47 13876] ACSetup: Connect2RLS end
[8/23/2022 0:07:47 13876] ACSetup: Connect2RLS end
[8/23/2022 0:07:47 13876] ACSetup: Connect2RLS end
[8/23/2022 0:07:47 13876] ACSetup: ReturnResult2UWP command: FirstLaunch result: Fail
[8/23/2022 0:07:47 13876] ACSetup: ReturnResult2UWP end


My internet is working fine. Could anyone help in this

Me and many others are facing the same issue and this issue is not limited to tuf gaming laptop as i own the same but also affecting rog laptops and pc. As far as my research goes this issue is from AC side because it is asking for .net software which is already installed into the computer but the application crashes. I had tried many ways to fix but neither work for me , for now only solution is to install the older version of it i.e rog live service v5.0.8.0 and disable the automatic update from microsoft store. Some one from Rog Discord server suggested to upgrade windows to 11 i didnt try that but now you have tested, the issue in not limited to windows 10 so which version you are running doesnt matter the problem is from AC's side.

Random_ wrote:
Me and many others are facing the same issue and this issue is not limited to tuf gaming laptop as i own the same but also affecting rog laptops and pc. As far as my research goes this issue is from AC side because it is asking for .net software which is already installed into the computer but the application crashes. I had tried many ways to fix but neither work for me , for now only solution is to install the older version of it i.e rog live service v5.0.8.0 and disable the automatic update from microsoft store. Some one from Rog Discord server suggested to upgrade windows to 11 i didnt try that but now you have tested, the issue in not limited to windows 10 so which version you are running doesnt matter the problem is from AC's side.


Thanks for your reply !!
So , its Ac setup issues which Asus devs should update.
I'm on W11, also tried old version which again forcefully updates to new version and causes same issue.

Hi guys,


ellie11 - You'll want to check Device Manager for any missing drivers, windows 11 doesn't install the chipset driver.

Random_ - You need windows 10 v1809 or later for Armoury Crate.

It asking for .net software sounds like a windows .net framework update. Was it anymore specific?

Maybe we can find the problem as the latest version of Armoury Crate is working fine for me on windows 11.

Here is the Armoury Crate Compatible Devices page. - https://www.asus.com/support/FAQ/1042459

Install version 3.2.3.0 then go to the update center, update Armoury Crate and all your devices. For good measure, first use the Armoury Crate uninstall tool. Click "Show all" in blue, it's the third download.

Select your operating system. - https://www.asus.com/supportonly/Armoury%20Crate/HelpDesk_Download/


94743

Nate152 wrote:
Hi guys,


ellie11 - You'll want to check Device Manager for any missing drivers, windows 11 doesn't install the chipset driver.

Random_ - You need windows 10 v1809 or later for Armoury Crate.

It asking for .net software sounds like a windows .net framework update. Was it anymore specific?

Maybe we can find the problem as the latest version of Armoury Crate is working fine for me on windows 11.

Here is the Armoury Crate Compatible Devices page. - https://www.asus.com/support/FAQ/1042459

Install version 3.2.3.0 then go to the update center, update Armoury Crate and all your devices. For good measure, first use the Armoury Crate uninstall tool. Click "Show all" in blue, it's the third download.

Select your operating system. - https://www.asus.com/supportonly/Armoury%20Crate/HelpDesk_Download/


94743



Thank for your reply !
All drivers in device manager are updated to latest one.

94744

I have tired the 3.2.3.0 for w11. Same as previous 502 error. I have searched, found many are facing this issue.
The same logs appeared which mentioned in Initial post. As per logs, AC setup is causing the issue.
If you need i can provide Armoury crate full logs from my end

Yes, if you'd like, you can use the Armoury Crate Lite Log Tool.

It's the fourth download in the link above.

Scroll almost halfway down the page to Armoury Crate Lite Log Tool in blue for instructions. - https://www.asus.com/support/FAQ/1041654/