Showing results for 
Search instead for 
Did you mean: 

Error Can´t open AsIO.sys!! (2)

Level 9
This error (in mini window) i see i must close it 3 times after restart or turn on pc always on Windows 11, Armoury -

ROG advised me to do a clean install of Windows 11 and I did (major pain in the *ss). Didn't install al suite II anymore (since the functionality in Armoury crate).

Issue is solved


Cooler Master Silent Pro Hybrid 1300W ATX
Asus ROG Maximus Z690 Extreme
Intel Core i9-12.900k
ROG Ryujin 360
Corsair DDR5 Dominator Platinum RGB 2x32GB 5600Mhz
Samsung 980 PRO 2TB M.2 SSD (2x)
Seagate Firecuda 1TB
ROG RTX3080-O10G-Gaming
Monitor 1: ROG STRIX XG349C
Monitor 2: Samsung HDTV T27D590
ROG Claymore
ROG Spatha X
ROG Balteus Qi
Windows 11

Level 8

Same here, after the in place Windows upgrade AI Suite stopped working. Used the nasty, useless downloaded uninstallers for all products but I keep getting the infamous Error Can´t open AsIO.sys!! (2) while trying to install AI Suite (no other Asus software are installed at this point). Anyone found a solution?
I just want to keep the fans silent. Asus hardware is very good, but the software is HORRIBLE, and I am being polite. dozens of services and processes running, bloating the system to do nothing but bother. Keep it simple: One app, one service, one process running (two if you want a watchdog). Stop bloating the operating system for once

This error message basically  means your registry is corrupt and is trying to load a driver you probably deleted on purpose.

Thanks for your response. I disabled services in the past, not drivers and did not alter the registry regarding Asus software either, in fact AI Suite was working without issues with the same configuration before the in place upgrade.
I did remove every single Asus App with the uninstallers and tried again. Turns out, as someone mentioned before, installing one of the most bloated software in history of computing (Armory crate), AI Suite setup is no longer displaying that particular error. That is, the solution for me was to install AI Suite only after Armory crate was deployed. 

Funny thing, neither open either after the requested reboot by AI suite setup (no errors shown this time during setup). Armory crate register an error in event log, but I don't really care for it, I just need AI suite, which refuse to start but doesn't return any error, nothing happens, it just does not open or register any event I can see.

The rest of the software installed works great, it is just Asus bloatware which refuse to load. And I won't clean install Windows just because this garbage won't start. I will build another rig without any Asus crapware before that. All I need to to control fans speed properly, I will keep searching for alternatives to AI Suite

The following steps are best for removing AI Suite III or for reinstalling it.

1. Run the Armoury Crate uninstall tool

2. Disable windows updates temporarliy

3.Delete any ROG device drivers for mice or keyboard that have provider name Asustek using the driver store explorer tool, then reboot. 

4. Verify that the ArmouryLiveUpdate Service was removed from windows service. It should be removed when the device drivers were deleted in step 3.

5. Run the AI Suite III cleaner program as administrator. Reboot. 

6. Re-enable windows updates, reinstall AI Suite 3 if desired.

Brief explanation why this works. The AI Suite III Cleaner does not do a full cleanup if the ArmouryLiveUpdate Service is installed.

Thanks again. I solved it differently. Summarizing, AsusFanControlService was the problem, which refused to start. And it did refuse to start because asComSvc wasn't running and asComSvc did not start because it needed AsusCertService, which was not disabled but set to manual in my Windows. 

The main problem is, none of these services have their dependences configured correctly: Windows services dependencies can be configured, so requirements (other services) services can be loaded up when needed. 

My recommendation to other facing these kind of errors is to install armory crate first, then AI Suite. Check the services I mention above are running: First AsusCertService, then asComSvc and finally AsusFanControlService, are running before launching AI Suite. 

The awful armory suite can be uninstalled once AI Suite is able to launch. I can confirm AI Suite works fine without armory suite (although it seems to be required for installation, for unknown reasons). I was able to run fans calibration and now I will be able to work and play without the fans spinning fast and loud for no reason with Windows 11 

There is never a reason to manually disable the services. In fact it is exactly when someone manually manipulates them that a problem occurs.

Level 7

Install the minimal amount of packages from Armoury (including AI Suite III), grab the updated 2023 version of AsIO.dll from AI Suite III folder (C:\Program Files (x86)\ASUS\AI Suite III), and overwrite the older AsIO.dll in the EZ Update folder (C:\Program Files (x86)\ASUS\AI Suite III\EZ Update\ASUS Update).   Run the Armoury Uninstaller, but keep AI Suite III and whatever else you want.  Uninstall anything you can from Programs and Features.

 I love ASUS hardware, but their software could improve.