cancel
Showing results for 
Search instead for 
Did you mean: 

Error 2005 - Help please

Kekz0r
Level 8
Hello, while trying to click on any of the items inside "Device" I get the Error code 2005
94756

I'm running the following:
Item Version
---- -------
Armoury Crate UWP App 5.2.12.0
ROG Live Service 1.5.11.0
Aura Service (Lighting Service) 3.05.66
Armoury Crate lite service 5.2.10
Aura Wallpaper Service 1.3.4.0
ASUS AIOFan HAL 1.1.49.0
ASUS AURA Extension Card HAL 1.1.0.18
ASUS AURA Motherboard HAL 1.3.4.0
ASUS Aac_GmAcc HAL 1.0.9.0
AacVGA 0.0.5.3
KingstonDram 1.1.12
AURA DRAM Component 1.1.18
ENE RGB HAL 1.1.39.18
ENE_EHD_M2_HAL 1.0.9.12
PHISON HAL 1.0.9.0
Patriot Viper DRAM RGB 1.0.9.4
Patriot Viper M2 SSD RGB 1.1.0.2
Universal Holtek RGB DRAM 1.0.0.3
WD_BLACK AN1500 1.0.14.0


I tried uninstalling twice with the tool from the support site. I tried the full Armoury Crate installer and the normal version.
This issue still persists...

Thank you in advance for any help
12,301 Views
26 REPLIES 26

Nate152
Moderator

Nate152 wrote:
A windows reinstall will fix it.


is the armory crate software that bad 😕 changing to another manufacturer would also solve is, but that does not help me, losing and reinstalling everything that works for 1 mailfunctioning application is a little drastic isn't it ?

Same problem here. I've installed a Gladius II mouse, it recognized it, installed drivers etc. and then in Armoury Crate device page I cannot access to Fan Expert, Motherboard and Mouse tabs: "error 2005".
Therefore I cannot configure my brand new mouse! And neither the fans etc.
I've tried to uninstall Armoury Crate with the tool, and then reinstall everything. Nothing, the same. Error 2005.

celmarco wrote:
Same problem here. I've installed a Gladius II mouse, it recognized it, installed drivers etc. and then in Armoury Crate device page I cannot access to Fan Expert, Motherboard and Mouse tabs: "error 2005".
Therefore I cannot configure my brand new mouse! And neither the fans etc.
I've tried to uninstall Armoury Crate with the tool, and then reinstall everything. Nothing, the same. Error 2005.


UPDATE: on 19th September Armoury Crate software updated and Device Tab became again working with access to the devices settings. No more Error 2005.

Nate152
Moderator
There were some updates today in Armoury Crate for my devices, try running the updates in the update center if you're able to.

Try disconnecting your ROG devices and reconnecting them.

Does this fix the 2005 error?

Nate152
Moderator
I also have the 2005 error, the device that is causing it for me is Fan Xpert.

Probably my fault. I have no fans connected to the motherboard but I clicked the auto tune just to see what would happen. I think it's throwing the 2005 error because it's trying to detect fans but there are none.

The uninstall tool didn't work for me so to fix it, I too will have to reinstall windows.

94856

Nate152
Moderator
Connecting a fan to a chassis fan header fixed the 2005 error in fan expert 4.

shadok77
Level 7
Same error in my case with device pages (motherboard, fanexpert & graphics.. but works flawlessly for aura wallpaper). I never uninstalled edge . I'm almost sure it worked at first installation, with a previous version (but can't remember numbers...)

Papa_Baphomet
Level 8

Ok, so it's June 3rf, 2023.
Just got my Rog Azoth.
And I have the same H 2005 error message. Cannot configure my keyboard at all.
I have both Edge and Chrome.
Uninstalled the Crate with the Uninstall tool. Re-installed. Nothing works.
I need some normal explanations here, what to do?

Re-installing Windows is not an option, this is bs to make one app work.

Thanks in advance.

P.S. My motherboard is also from ASUS and I get the same error message for it as well.

I am having the same issue right now with the Harpe Ace. Can't configure anything. Getting the 2005 error code