cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot install Armoury Crate

asususer11
Level 7

Cannot install. I have followed the official steps properly. It has been a long time issue for my case. I guess we have to check the logE file.

623 Views
7 REPLIES 7

Nate152
Moderator

Hello asususer11,

Try this....

Use the Armoury Crate uninstall tool to remove any left over files from previous versions. In the link below, select your operating system, click "Show all" in blue, the uninstall tool is the third download.

Armoury Crate - Support (asus.com)

Once uninstalled, reboot.

Then install Armoury Crate version 3.2.9.1 (first download) and go to the update center and check for updates. Armoury Crate will update to version 5.6.10.0

How does it go after using the uninstall tool and reinstalling?

Armoury Crate.png

 

Hi

It doesn't solve my problem. My case is the software cannot be installed properly at all.  The app will just show a blank page after installing. I've sent the LogE file through the form. Could you please help to check? Thanks.

Nate152
Moderator

Thank you for trying, sorry to hear it didn't work. I'm not involved with reading the logs, that's strictly with ASUS.

Let's try something else.

Open Task Manager, click Services and check if you have an AsusCertService process.

Make sure that it is running, if it is stopped, start it and see that it shows running, then try installing Armoury Crate again.

How does this go?

asuscertservice.png

Nope, still not working, still a blank page.

I don't even have "AsusCertService" in my services tab.

Nate152
Moderator

Hello Azora

Check the Armoury Crate device compatibility list to see if your devices are compatible.

[ASUS Armoury Crate] Armoury Crate Compatible Devices | Official Support | ASUS Global

If your devices are compatible, then I'll suggest to refer to my first post in this thread. If using the Armoury Crate uninstall tool and reinstalling doesn't work, this could point to your operating system missing some files that Armoury Crate needs for installation. In which case, the only other thing I know to do is to reinstall windows. 

 

 

 

 

 

Thanks for the advice, it's compatible and I've done and redone the proper installation 10 times but still doesn't work

I can't afford formatting right now -_-

Nate152
Moderator

Another suggestion is to reset you pc to defaults and try the installation again.

To reset your pc to defaults...

Enter the bios and hit the F5 key, then hit F10 and Enter to Save and Exit.