cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot install Armoury Crate, displays error 4142

Rat_King
Level 7

Hello there. As my previous post got unexpectedly locked without getting a solution to my problem, I'm posting it again to hopefully be able to get somewhere with this.

It's been a while now that the keys for modes and opening armoury crate don't work. I tried opening the app but couldn't at all, so I decided to uninstall it and install it again, which ended in a failure with the error 4142 displayed.

I tried to download the latest version. All of my drivers are updated. I have already done a system recovery with the "restore preinstalled apps". Still not working. I have tried again to uninstall and install, but it still isn't working. No viruses found with bitdefender (free version). I haven't tried installing Armoury Crate again today, but the same error shows up and I can't finish the installation. Even using the uninstall tool didn't work.

Here are the informations I think could be useful. Ask if you need some more.


ROG Strix G531GU_G531GU
Processeur Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz 2.59 GHz
Édition Windows 11 Famille
Version 22H2
Installé le ‎04.‎06.‎2023
Build du système d’exploitation 22621.2215
Expérience Windows Feature Experience Pack 1000.22662.1000.0

NVIDIA GeForce GTX 1660 Ti
Version du pilote 537.13


Thanks and have a nice day.

191 Views
3 REPLIES 3

Bogus5
Level 12

Have you tried installing the full "Armory Crate" installation package (3 GB)?

Hello, yes I tried today but it still didn't work. Error 4142 showed again. 😕

Do you run Instaltor with Admin privileges?