cancel
Showing results for 
Search instead for 
Did you mean: 

Can't update the Armoury Crate

krischan828003
Level 7

It keeps showing unable to connect to the internet but I checked my firewall it should be work. I have tried to turned off my router and turn on again but it still not working. And I have already reinstall the AC. 螢幕擷取畫面 (69).png

46,001 Views
156 REPLIES 156

1. I lose all my Game Library after update to 5.8.9.0, tried to add games and just blank then failed
2. All my Asus products have been registered but sometimes still notify Need to Register. How to register the products mean while my products have been registered?
3. A week ago I got update 5.8.9.5 it fix all my problems, but a few days later Asus has deleted the update and go back to 5.8.9.0 so I get my problem again


My Hardware:
AMD Ryzen 5 5700X / Asrock Phantom Gaming RX 6700XT / Asus ROG Strix B550F Gaming Wifi II / Corsair Vengeance RGB RT DDR4 3600 32GB / Samsung 980 Pro 2TB / Seagate Firecuda 530 1TB / Seagate Barracuda Harddisk 2TB / Seasonic Focus Gold GX-750 750W / Monitor Lenovo L29W-30 Ultra Wide

MaxRay
Level 7

It sorted itself out, asus might have rectified the problem. Able to update now

17131859180843042556960503053028.jpg

Vanatorul_GR
Level 7

I keep having it today, and all firewall access has been verified, and the connection is stable

Armoury Crate, Update problem, 1.jpgArmoury Crate, Update problem, 2.jpgArmoury Crate, Update problem, 3.jpg

Do you have Microsoft Store account? If so, loggin; set in setting -> App Update 'OFF' and try to update UnifyDGDII.

Best practice is to uninstall ARMOURY (better if removed from REGs+anywhere);  download 3.2.9.1 Armoury_Crate_Full_Installation_Package (for local installation 'no internet needed', not sure if new ver. available); update it; then AURA won't work is asking for update; disable Microsoft App Update; update AURA again.

Nothing is free here, perhaps Aura Sync Addessable LED strip/mouse/Thor or any other won't sync correctly!!!! and as before Aura Performance Mode never stays 'OFF'.

mysquen
Level 9

Armoury crate can be get better, they can write it better in another language without writing UWP, I think the program has started to get worse, the updated application or SDK list is now not visible anymore, I deleted it with the uninstaller then install again but, I formatted it again, it is the same, I don't understand why it is so broken.

screenshot_20240520134945012.png

For any issues with Armoury Crate, you may report them in this thread. Please follow the instructions on how to submit. 
The devices and components section should be populated, do you have any ROG devices connected? 

_____________________________________________________________
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin

Nefer26
Level 9

I'm also having this issue.