Showing results for 
Search instead for 
Did you mean: 

Can't update the Armoury Crate

Level 7

It keeps showing unable to connect to the internet but I checked my firewall it should be work. I have tried to turned off my router and turn on again but it still not working. And I have already reinstall the AC. 螢幕擷取畫面 (69).png

156 REPLIES 156

Try to logged off your armoury create profile and sign in again..then do update it is perfectly work now

Level 7

What worked for me (no reinstall required) a simple solution:

Update failed with unable to connect error - go to user centre - logout, if logged in (for me this page was blank hence why I toggled to refresh) - toggle over to china tab then back to login page - page loaded - log in to Asus - try update again.

Mine worked after logging in, with no issues.

this worked for me too - thanks

Yes that works. Cheers 👍

Yes I updated...hoo it's a server error..I logged off and logged in's perfectly work now...this is the perfect solution..

Krobelus' solution worked for me too.

@Krobelus instructions unfortunately didn't work for me.
So I went about it a little differently:
User Center -> Logout -> +Switch to China Service -> Update attempt -> Update completed successfully -> Uswer Center -> Login -Y done.

The update went through but Armory Crate remains at version

But no new update to appears anymore.

Intel Core i7 13700K / AiO Fractal Design Lumen S36 v2 RGB / Asus Rog Strix Z790-F Gaming WIFI / Corsair Dominator Platinum DDR5-5600 64GB (4x 16GB) / Asus TUF RTX 4070 ti OC / 4x Samsung 980 pro 1TB / Seasonic Prime GX 850 W Gold / Fractal Design Meshify 2 Lite RGB Black TG Light Tint / Monitor AOC Q27G2S/EU (WQHD)

จะไปลองดู  update  ดูครับ

Level 7

Just updated correctly, without errors due to (fake/false) internet connection, the UNIFYDGII. Good! 

Level 7

Bueno pues parece que esta mañana para mi se soluciono soloo realizaron alguna correccion  y actualizo sin problemas