Showing results for 
Search instead for 
Did you mean: 

Can't update the Armoury Crate

Level 7

It keeps showing unable to connect to the internet but I checked my firewall it should be work. I have tried to turned off my router and turn on again but it still not working. And I have already reinstall the AC. 螢幕擷取畫面 (69).png


Accepted Solutions

Level 9

Using the armoury crate uninstaller and reinstalling, fixed the issue. One thing i noticed doing this is my armoury crate went from being a standalone program to now being on the microsoft store as an app. This could be asus way to migrate to the windows store version since it seems easier for them to keep updated with. Idk if it correlates with not accessing the update server but could be a mismatch since they have the microsoft app now

View solution in original post

156 REPLIES 156


Hello krischan828003

If you have a stable internet connection, try resetting the motherboard bios to default settings.

Then try installing Armoury Crate.





It is and has been always at default setting. I should not have to wipe out my BIOS password just to do this stupid update.

Everything else updated except for the UnifyDGII .... what the hell is going on?

Your reasoning is very well stated, you don't have to touch anything in the BIOS, since you have it configured for your system, if the application worked as God intended, and was developed as God intended, it would have to be loaded, and not touch anything in the BIOS.

Yes you are right I think this could be in Asus side because every single user faced this issue in community..soon they will address it

Level 7

Having the exact same issue on two different builds guess no one knows what's goin on.


This is a lie, they have not solved anything, the only thing they have done is DELETE the update, if you remember they updated from to, once applied in a hurry this weekend April 7, 2024 they have done DELETE so that the update to is not applied, and if you notice, YOU STILL HAVE Version
They must have given the DEVELOPER some trouble. Porque limita mi respuesta QUE ES LA CORRECTA?

Level 7

Experience the same issue as well. Hope there is a resolution to this soon.

Level 7

I'm also having this issue. Went into my firewall and whitelisted AsusUpdate but it doesn't change anything. I guess we are all waiting for the same fix.

Level 7

same, probably an Asus issue