Showing results for 
Search instead for 
Did you mean: 

Can't update the Armoury Crate

Level 7

It keeps showing unable to connect to the internet but I checked my firewall it should be work. I have tried to turned off my router and turn on again but it still not working. And I have already reinstall the AC. 螢幕擷取畫面 (69).png

156 REPLIES 156

Level 7

Same here. No connection to the interwebs. I whitelisted "AsusUpdate.exe", no change, I turned off the firewall alltogether, no change. My errorcode also was 0x800421F7.

Level 7

I'm having he same issue here also.

Level 7

Screenshot 2024-04-05 005152.png


I have the same issue, I never had an issue with updating Armoury Carte before and I made sure I allowed "AsusUpdate.exe" in my firewall. Now I can't use Aura Creator because it won't allow me to continue using the application unless I do the update.

Things I tried and didn't solve the issue:

  • Whitelisted "AsusUpdate.exe" in my firewall before starting the update.
  • Disabled my firewall before starting the update.
  • Disabled my firewall and antivirus before starting the update.
  • Uninstalled Armoury Create using the remove tool > Installed a fresh version > Started the update.
13900K @5.8 | ROG STRIX Z790-E GAMING WIFI | 6000 CAS36 | TUF GAMING RTX 3080 OC

Level 7



ROG Maximus XIII Hero (WiFi 6E) Z590 LGA 1200(Intel®11th/10th Gen) -Motherboard
Asus ROG Strix 3090 OC

Level 8

Same issue here! So sad a PC company as large as ASUS has this issue!

Level 7

I feel for everyone here, I am also experiencing the same problem. It won't even allow me to sign into my account to download Aura Wallpapers. Hopefully ASUS gets this fixed soon, would really hate to resort to just doing away with Armoury Crate for good. I've had a great experience up until this annoying issue.

Level 8

I have the same issue, but only on my ROG Strix laptop and not my custom pc.

I am the internal affairs bureau

Level 7

I just updated my ROG Strix laptop and had Windows update screw up the AMD graphics drivers and Adrenaline, causing me to resort to re-installing it to get it working again. Now I've discovered this issue with AC and have tried everything others have by whitelisting AsusUpate.exe, turning off my Firewall completely before trying the update, etc. Windows update timing and things breaking is SUS, but no real evidence.  Hoping ASUS gets on this as well, because Aura creator no longer works and whines that AC needs to be updated. C'mon ASUS!

Level 7

im also facing the same error and cant update, 0x800421F7 .

Level 7

Here is one more with error 0x800421f7, I hope they solve it soon.