cancel
Showing results for 
Search instead for 
Did you mean: 

ASUS Windows Dynamic Lighting Plug-in has failed to install

Gennady21
Level 8

ASUS Windows Dynamic Lighting Plug-in has failed to install, the error always is the same 4151

PS: And please fire the developer who doesn't know that Windows can be installed on more than just the C drive.
Or tell this “guru” that he needs to use SHGetShellFolderPath as Microsoft wrote in the documentation and not hardcode names.

6,743 Views
31 REPLIES 31

caveman8080
Level 7

I was having the same problem and was able to fix it by force repairing the install via the command line.

Unfortunately, I uninstalled Armoury Crate and I don't remember the exact location of the installer. It should be nested in the Asus default installation folder under "Program Files" were Armoury Crate keeps it's temporary downloads. Look for a folder named 1.4.0.0

Once you find it, open a command prompt as Admin and then run "AacAmbientSetup.exe /repair /silent /norestart" . You might see some windows pop-up for a split second and then the plug-in should be installed. If Successful, it will clear it from the update list and be under the "up to date" list.


I have manage to find it but can not repart it . I try putting every name of the file in but it does not work . Is it this file ?

ryuga_souichiro_0-1700760275911.png

 

That's the one. The command to run is "AacAmbientSetup.exe /repair /silent /norestart"

I tried running the command as recommended.

Screenshot 2023-11-23 194129.png

Didn't have any luck, after loading armory back up the failed update was still there, and still failed to install.

 

So I tried running the AacAmbientSetup.exe Screenshot 2023-11-23 194328.png

and it's failing to install. Taking a look at the log the .msi file is erroring out.

It looks like running it with the /repair didn't error out, not sure why didn't force the package to install.

Just running the installer will look for the default installer that was used when Armoury Crate was being installed but gets removed after it finishes installing. That why Asus had to create the Uninstall tool to remove all of the components it installs a long the way.

The only other way I can think of is to copy the AacAmbientSetup.exe and placing it somewhere else on your computer and then use the Armoury Crate Uninstall Tool to remove everything. You can then run the AacAmbientSetup.exe installer in the command line before re-installing Armoury Crate to have it already installed.

I was able to get it to install after trying a bunch of different things and this is why I just ended up completely uninstalling Armoury Crate and never re-installed it. That or you'll have to wait for Asus to find and push a fix.

I'm getting the exact same error as you. Our setup logs look identical.

[7A34:7A38][2023-12-12T09:40:33]i301: Applying execute package: Setup64, action: Install, path: C:\ProgramData\Package Cache\{02DBBC13-0422-43B8-8C72-F1983DADD1FA}v1.4.0.0\AacSetup.msi, arguments: ' ARPSYSTEMCOMPONENT="1" MSIFASTINSTALL="7" UNINSTALLER_PATH="{089a9b2c-cc3b-4fad-91ba-34243342505a}\AacAmbientSetup.exe"'
[7A34:7A38][2023-12-12T09:40:35]e000: Error 0x80070643: Failed to install MSI package.
[7A34:7A38][2023-12-12T09:40:35]e000: Error 0x80070643: Failed to execute MSI package.
[3A64:2C74][2023-12-12T09:40:35]e000: Error 0x80070643: Failed to configure per-machine MSI package.
[3A64:2C74][2023-12-12T09:40:35]i319: Applied execute package: Setup64, result: 0x80070643, restart: None
[3A64:2C74][2023-12-12T09:40:35]e000: Error 0x80070643: Failed to execute MSI package.

I've run the System File Checker in Windows to make sure my installation was healthy and I still get the same error. I've also run the installation interactively to see if it would popup an error during the installer progress, which it doesn't. There's something wrong with this MSI package. Sure wish ASUS would fix it.

This was resolved with ASUS WDL HAL v1.9.0.0 last week. How did you go?

_____________________________________________________________
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin

I actually found it in the updates yesterday. Everything is installed correctly as far as I can tell, only problem is Armory crate is not showing in background light control in windows settings. Been trying to find a fix but so far nothing

The updated v. 1.9.0.0 finally installed successfully for me on Win 11 Pro.

ryuga_souichiro
Level 9

ryuga_souichiro_0-1700790332554.png

I try putting this in but it keeps saying this