cancel
Showing results for 
Search instead for 
Did you mean: 

Asus ROG Ryujin II 360 - Installed armory crate - unknown devices?

ridethewhirlwin
Level 7
After installing armory crate with the version listed on the Ryujin II support page which is verison 3.1.2 from 12/21.
https://rog.asus.com/us/cooling/cpu-liquid-coolers/rog-ryujin/rog-ryujin-ii-360-model/helpdesk_downl...

After installing this everything seems to be working correctly however, when I went into device manager and there are a few unknown devices that were installed.

Can anyone shed any light into how to address these unknown devices?

92202
616 Views
3 REPLIES 3

Jimbo93
Level 12
ridethewhirlwinds wrote:
After installing armory crate with the version listed on the Ryujin II support page which is verison 3.1.2 from 12/21.
https://rog.asus.com/us/cooling/cpu-liquid-coolers/rog-ryujin/rog-ryujin-ii-360-model/helpdesk_downl...

After installing this everything seems to be working correctly however, when I went into device manager and there are a few unknown devices that were installed.

Can anyone shed any light into how to address these unknown devices?

92202


Hi ridethewhirlwinds, Have you installed the drivers for your motherboard? What are your system specs?

Jimbo93 wrote:
Hi ridethewhirlwinds, Have you installed the drivers for your motherboard? What are your system specs?


I'll double check to make sure everything is up to date. Have you come across issue with the Ryujin II/Armoury Crate?

I do not have ryujin. *Just looks like you are missing drivers.