cancel
Showing results for 
Search instead for 
Did you mean: 

Asus Aura and RGB no longer working on a STRIX G17 laptop (Windows 10)

DBDigital
Level 7

A few days ago the Amory Crate on a STRIX G17 laptop (Windows 10) stopped showing or offering fan controls.  The area was blank and didn't give an option to choose settings (turbo, manual etc).  It also wouldn't show any of the usual stats (processor etc).  I tried reinstalling Armory Crate and no change.  So then I used the Armory Crate uninstall tool.  This kept failing and asking for a reboot, in an endless cycle.  After reading here about such a problem I went into the Windows 10 app add/uninstaller and removed Aura creator and another Asus driver (I don't recall which one).  Then Amory Create uninstaller worked fine.

Then I used the Armory Install tool and let it run.  After a long time it did install it and fan controls etc were all back.  However, Aura/RGB no longer works.  The keyboard etc lights don't work at all.  I have tried uninstalling and reinstalling it but no change.  I also tried reinstalling Aura creator but no change on that either.

Under Aura Sync in the Armory Crate it does show the device at least (G712LW) but I can't seem to get any lights to work.  It certainly doesn't flash like they used to when turned on etc etc.  This unit only had the default settings, nothing custom.

Any ideas?

346 Views
1 ACCEPTED SOLUTION

Accepted Solutions

DBDigital
Level 7

Well I fixed it.  I uninstalled Armory Crate with the uninstaller, of course it wouldn't complete on its own and I had to remove the several items relating to Aura (any I could find) and the Armory Crate itself via windows 10 add/remove programs/apps.  Once I did that, the Armory Crate installer could finish and complete.

Installed Asus control interface v3 (up until now I had been using V2 which always worked before).

Rebooted

Installed Armory Crate via its installer but did NOT let it install Aura creator as well (took a LONG time as usual).

It worked!  About  half way through the Armory Crate install the RGB lights on the keyboard etc started lighting up.  Shocked me as I had done so much uninstalling and reinstalling the last few days, I had got to the point I thought it would never work again after reading so many posts with similar problems.

I don't know if not having Aura Creator installing at the same time made any difference or not.  I doubt it but I mention it here as part of the exact steps I used.  I hope this helps someone else with a similar problem.

View solution in original post

1 REPLY 1

DBDigital
Level 7

Well I fixed it.  I uninstalled Armory Crate with the uninstaller, of course it wouldn't complete on its own and I had to remove the several items relating to Aura (any I could find) and the Armory Crate itself via windows 10 add/remove programs/apps.  Once I did that, the Armory Crate installer could finish and complete.

Installed Asus control interface v3 (up until now I had been using V2 which always worked before).

Rebooted

Installed Armory Crate via its installer but did NOT let it install Aura creator as well (took a LONG time as usual).

It worked!  About  half way through the Armory Crate install the RGB lights on the keyboard etc started lighting up.  Shocked me as I had done so much uninstalling and reinstalling the last few days, I had got to the point I thought it would never work again after reading so many posts with similar problems.

I don't know if not having Aura Creator installing at the same time made any difference or not.  I doubt it but I mention it here as part of the exact steps I used.  I hope this helps someone else with a similar problem.