cancel
Showing results for 
Search instead for 
Did you mean: 

armouryswagent

Crasje
Level 12
Every time I start my computer, there is a window open displaying nothing with the name 'armouryswagent'.

What is that? I didn't have that until I uninstalled and reinstalled armoury crate in an effort to show my XG349C monitor in the armoury crate (which was a fail)

😞

Cooler Master Silent Pro Hybrid 1300W ATX
Asus ROG Maximus Z690 Extreme
Intel Core i9-12.900k
ROG Ryujin 360
Corsair DDR5 Dominator Platinum RGB 2x32GB 5600Mhz
Samsung 980 PRO 2TB M.2 SSD (2x)
Seagate Firecuda 1TB
ROG RTX3080-O10G-Gaming
Monitor 1: ROG STRIX XG349C
Monitor 2: Samsung HDTV T27D590
ROG Claymore
ROG Spatha X
ROG Balteus Qi
Windows 11
😉
941 Views
31 REPLIES 31

SStArlord_97
Level 8
Crasje wrote:
Every time I start my computer, there is a window open displaying nothing with the name 'armouryswagent'.

What is that? I didn't have that until I uninstalled and reinstalled armoury crate in an effort to show my XG349C monitor in the armoury crate (which was a fail)

😞


It seems somehow related to rog claymore.
Sometimes the lighting desynchronizes.

SStArlord_97 wrote:
It seems somehow related to rog claymore.
Sometimes the lighting desynchronizes.


Any idea how to prevent it?

I already uninstalled - reinstalled it.

Cooler Master Silent Pro Hybrid 1300W ATX
Asus ROG Maximus Z690 Extreme
Intel Core i9-12.900k
ROG Ryujin 360
Corsair DDR5 Dominator Platinum RGB 2x32GB 5600Mhz
Samsung 980 PRO 2TB M.2 SSD (2x)
Seagate Firecuda 1TB
ROG RTX3080-O10G-Gaming
Monitor 1: ROG STRIX XG349C
Monitor 2: Samsung HDTV T27D590
ROG Claymore
ROG Spatha X
ROG Balteus Qi
Windows 11
😉

When will fix it??????

I get that as well and sometimes after playing a game. One time it made my entire desktop grey and had to restart the computer. 5950x on a Dark Hero.

Englishman_Xper
Level 9
I did not upgrade the armoury, only updated the Device Kit that is mandatory and now i get this armouryswagent in every reboot.

Just went through multiple update loops with AC and now I have this problem. Just title bar above Windows button/Search bar. 😞

RobertoSampaio
Level 8
I have the same issue with ARMOURYSWAGENT.

Nuka_Pete
Level 7
I have the same problem. armouryswagent window evert time I boot up.

The RGB lighting randomly desynchronizes too now.

I removed ArmorySwAgent.exe and it didn't appear every time I restarted the PC. After deleting it I checked the Armory Crate app again and it worked fine. Try to do it my way.
C:\Program Files (x86)\ASUS\ArmouryDevice\dll\SwAgent

Nuka Pete wrote:
I have the same problem. armouryswagent window evert time I boot up.

The RGB lighting randomly desynchronizes too now.



Same issue here after updating. I registered here just to try to get a resolution.