cancel
Showing results for 
Search instead for 
Did you mean: 

ArmouryCrate stuck on "Installing components for the Connected Devices"

mariusi3333
Level 7
I am trying to install for some weeks ArmouryCrateInstaller v3.0.11.0 (Win 10, ROG Strix G17 G712LW)
Did:
- used Geek Uninstall to remove all ASUS/AURA related: ASUS Framework Service, AURA lighting effect add-on, AURA lighting effect add-on x64, AURA Service, ROG Live Service
- used Armoury Crate Uninstall Tool V1.1.2.0
- restarted system
- used the installer but after a while it hanged on "Installing components for the Connected Devices and it fails after ~30min
Tried these steps multiple times in the last 2 weeks, including with firewall disabled.
Also, anything else I found posted in other threads (reddit, youtube) about this problem.
Windows is freshly installed (<1month).

I collected the logs from ProgramData here: https://drive.google.com/file/d/1m9Dj1quZkifI6Buu24Elk5ZWl4E5_iqn/view?usp=sharing

Contacted ASUS Support (EU) with clear indication it happens for other people, but they basically said "all these people have refused to reinstall Windows" and they can't do anything with the installation logs.
6,005 Views
27 REPLIES 27

Peyman1354
Level 8
hi.i had similar issues which i managed to solve.i guess many people have this issue.
and the problem is after u uninstall everything there are still files in the registry key which need to be removed.hope this is help.

1-uninstall the aura and armoury crates with armuory crates uninstaller then restart ur pc

2-make sure u remove all of the files in the folder Locations:

C:\Program Files (x86)\ASUS

C:\Program Files\ASUS

C:\ProgramData\ASUS

%LocalAppData%\ASUS

3-go under this Registry Entries folders and remove anything related to asus ,

a) Computer\HKEY_CLASSES_ROOT\
b) HKEY_CURRENT_USER\Software\ASUS
c) HKEY_LOCAL_MACHINE\SOFTWARE\ASUS
loctae all the Registry Entries and delete anything related to asus under those folders.

4:restart ur pc,turn off windows firewall or any others and try to install armoury crate again

hopefuly this will resolve ur issues.
let me know if u got questions.

Asus servers can be problematic at times you may have to uninstall using the uninstaller and then reinstall to try again, if been noticing it as well now, its probably why everyone is having such inconsistent experience, missing devices can also be a result of this.

Peyman1354 wrote:
hi.i had similar issues which i managed to solve.i guess many people have this issue.
and the problem is after u uninstall everything there are still files in the registry key which need to be removed.hope this is help.

1-uninstall the aura and armoury crates with armuory crates uninstaller then restart ur pc

2-make sure u remove all of the files in the folder Locations:

C:\Program Files (x86)\ASUS

C:\Program Files\ASUS

C:\ProgramData\ASUS

%LocalAppData%\ASUS

3-go under this Registry Entries folders and remove anything related to asus ,

a) Computer\HKEY_CLASSES_ROOT\
b) HKEY_CURRENT_USER\Software\ASUS
c) HKEY_LOCAL_MACHINE\SOFTWARE\ASUS
loctae all the Registry Entries and delete anything related to asus under those folders.

4:restart ur pc,turn off windows firewall or any others and try to install armoury crate again

hopefuly this will resolve ur issues.
let me know if u got questions.


I have the same problem. So you have to practice this procedure to solve? I'm always afraid to put my hand in the system registry ...

Miky2147 wrote:
I have the same problem. So you have to practice this procedure to solve? I'm always afraid to put my hand in the system registry ...


That process didn't work for me. Also not great messing with the registry, can break a lot of stuff. You should not have to in order to get one program working!

cindernat wrote:
You should not have to in order to get one program working!


Exact. So what do we need to do to fix?

Miky2147 wrote:
Exact. So what do we need to do to fix?


Wish I could tell you, but still waiting for assistance with my issues from Asus (aside from getting me to reinstall Windows as per their suggestion).

Reinstall Windows for only 1 broken program? Unacceptable!

Miky2147 wrote:
Reinstall Windows for only 1 broken program? Unacceptable!


agree

There is a bug in the installer which makes it just stop at "Installing components for the Connected Devices" if you choose to install both AC and AURA Creator (also AC... well)

So I tried a lot of stuff, and here is what worked no problems/hacky methods using just the provided uninstaller and installer tool https://www.asus.com/supportonly/Armoury%20Crate/HelpDesk_Download/

Steps:
1. Uninstall Armoury Crate using the uninstall tool
2. Restart to fully apply changes
3. Open the Install Utility, and instead of selecting 'Both Armoury Crate and AURA Creator', choose to install only AURA Creator.
4. Installation will complete quickly -> Restart to fully apply changes
5. Confirm that AURA Creator is working fine (you can update the aura creator related stuff from the three dots menu inside it)
6. Open the Install Utility and now choose to install only Armoury Crate.
7. This should work, will take some tie. It would look like it gets stuck at "Installing components for the Connected Devices" but it will not be stuck this time, will be completed.
8. Restart to apply changes
9. done