cancel
Showing results for 
Search instead for 
Did you mean: 

Armoury Crate V5.7.6.0 & V5.7.9.0 / AURA Creator V3.7.6.0 [Report here if any issues]

MasterC
Community Admin
Community Admin

A new Armoury Crate major release is now available. This is the official thread to report issues.

Please Read First:


Uninstall legacy Aura Sync software if already installed.
Always uninstall Armoury Crate using our uninstall tool (DO NOT remove or delete manually) - now included in the standard installer (right-click on icon in Windows Start Menu)

Uninstall.png

DO NOT delete files manually after uninstalling Armoury Crate
DO NOT modify the registry
Try to perform a power cycle to resolve lighting issues (shutdown and unplug power supply for at 30 seconds)
Forms MUST be completed and submitted in order to be processed.
Forms from non-forum members will NOT be processed
Must post a brief description in this thread (do this before filling in a form) to receive status updates.



----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Must read before reporting issues:

1. THIS IS NOT A THREAD FOR GENERAL CHAT, please report issues ONLY (try to find related threads or create a new one)
2. Try to reboot the system after updates are installed, and check again.
3. DO NOT report issues if facing improper uninstallation or registry issues - please resolve first
4. Revert system to stock speeds to check if errors are caused by excessive overclocking (even if overclock was stable previously)
5. Verify and confirm issues before reporting (do not make multiple posts while still in the process of troubleshooting)
6. Post a brief description of your issue in this thread (less than 50 words)
7. Record and generate a log (change the extension from .LogE to .txt). Prepare some screenshots and photos if applicable.
8. Complete the online Google form: Click HERE  to submit a form
9. Save the link to the form in case you need to revise or upload additional files (do not submit multiple form for the same issue).

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
How to record a log

MasterC_1-1700099293189.png

First, check the Record log box to start recording (Setting/About/App diagnostics)
Agree to the disclaimer
Replicate the issue you are having (reboot if necessary - the log tool will keep running)
Click on the Generate log data button
Save the log file to a location of your choice. (Avoid locations synced to OneDrive)
Stop the recording
Remember to upload this log file to the Google Form (change file extension to .txt first)

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Is my product supported in Armoury Crate & Aura Creator?
Note: There is a separate list for Aura Creator compatibility.
https://www.asus.com/us/support/FAQ/1042459

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Installation Error?

Download and install Armoury Crate Lite Log Tool v1.0.6.0
https://dlcdnets.asus.com/pub/ASUS/mb/14Utilities/Armoury_Crate_Lite_Log_Tool.zip

For more info:
https://www.asus.com/support/FAQ/1041654/
Fill in the Google Form and attach the generated log there.

 

Download Update:

Please install using Armoury Crate Installer V3.2.6.1 (approx: 2 MB), download link here:
https://dlcdnets.asus.com/pub/ASUS/mb/14Utilities/ArmouryCrateInstallTool.zip

Full installation package V1.1.2.2 (approx: 3GB) here:
https://dlcdnets.asus.com/pub/ASUS/mb/14Utilities/Armoury_Crate_Full_Installation_Package.zip
(V5.6.8.0 will be installed without internet connection, requires internet connection to upgrade to V5.7.6.0)

 

Release Notes:

See Release Notes 

_____________________________________________________________
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin
1,054 Views
202 REPLIES 202

Audio SDK v3.01.19 just publish to fix the sound profiles issue, you may update now. 

image.png

_____________________________________________________________
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin

Any update on a fix for the lighting service memory leak?  Even after disabling it and multiple reboots my page file is still stuck at 10x its normal allocation size a week later.

Have you noticed how they reply to a lot of other smaller issues here but COMPLETELY ignore those of us suffering from the memory leak? At the very least they could/should acknowledge a problem and that they are working on a fix, if it's not as widespread as I think it is (most users will have NO IDEA that Lightning Service is the reason their PC is going belly up if they leave it on long enough) then at least ask for details, etc...

But nah, nothing. Silence. Pesky customers having the audacity to criticize our perfect software! Let them eat cake!

what is this that you're talking about , my PC usually have some kind of intermittent issue and when this happen , My rog delta disappear out of the device list and when I check the reliabilty monitor in windows , it shows that armoury audio agent crash , is this what happened 


@flyinion wrote:

Any update on a fix for the lighting service memory leak?  Even after disabling it and multiple reboots my page file is still stuck at 10x its normal allocation size a week later.


this is ok. mine took about 2-3 weeks to shrink back to normal values) set it manually if you have not enough ssd.

having no updates on memory leak issue is weird but i already got rid of armoury crate and feel happy


@skiftcha wrote:

@flyinion wrote:

Any update on a fix for the lighting service memory leak?  Even after disabling it and multiple reboots my page file is still stuck at 10x its normal allocation size a week later.


having no updates on memory leak issue is weird but i already got rid of armoury crate and feel happy


I would get rid of it, but need it to handle RGB for all my fans.  Probably replacing them soon with a bunch of Corsair Link stuff though and then I won't need AC for anything.  

JayRos
Level 9

I can see that my issue still appears as not-fixed in version 5.7.9.0. I also can see that another user reported the same issue that I have ( @ChangSinior ), and he described it better than I did. So I'm going to use his description to report it again. Why? Because I think I find the solution and I'm going to be very detailed now, hoping that your support team will be able to resolve this in future releases. I hope my post doesn't get lost @MasterC.

 

The issue

  • Silent Mode is no longer silent with Armoury Crate 5.6.8.0, 5.7.6.0 and 5.7.9.0

Device:

  • ASUS TUF FX505DT, 2019 gaming laptop.

Description (as detailed by ChangSinior user):

  • The past years, from 2019 to 2022, the CPU voltage in Silent Mode used to stay at around 690mV up to around 850mV. Now the voltage in Silent Mode is constantly over 1000mV, which makes fans go brrrrrrrrrrrrrrrrrrrrrrrrrr even in Silent Mode.
  • The CPU speed used to stay at around 1366mhz up to around 2600mhz, and the fans used to spin at around 2300RPM up to 3300RPM, sometimes the fans even turned off entirely at around 40°C. Now, due to the increase in voltage, the fans spins at around 2700RPM up to 3500RPM in SILENT MODE, and they don't turn off, not even at 38°C idle.

I've already tested in a fresh installation of Windows 11 Pro. With all drivers from the ASUS support page for my laptop.

I have two screenshots to compare how does Armoury Crate should look like when it is working correctly, and how does it look now that it hasn't been working correctly. You can see the CPU voltage in silent mode is just wrong.ArmouryCrateComparison.jpg

 

This is also reflected in Windows Power and sleep settings. When Armoury Crate is working as it should, Windows doesn't allow me to change power modes, since they are being controlled by Armoury Crate. You can see in the next screenshot.

windowspowermodes.jpg

 

How did I fix it?

  • I went back to the past, when everything was working. I found an old Windows 11 Pro USB that has windows updates up until january 2023 and I found an old Armoury Crate Full Installation Package 1.1.2.2. And now everything works perfectly as it should. What changed in Windows 11 or in Armoury Crate between January 2023 and November 2023 (when my issues started)? I don't know. I don't have access to every Windows 11 version (since they do a Cumulative Update every month) and I don't have access to every Armoury Crate version, so I can only tests that this combination works as it should.
  • Hint: In October or November, Windows 11 introduced new power saving modes and enhancements in a Windows update. Maybe you need to check this? I don't know.

 

Non-related issues that should be checked by ASUS team:

  • Any version of Armoury Crate, including the latest 5.7.9.0, install a very old driver for the AMDRyzenMaster Device: version 1.3.0.0. This is already no longer signed by Microsoft, forcing Windows to deactivate this device. As a consequence, Armoury Crate doesn't show the temperature and the voltage of the CPU.
  • To fix this, you need to force the device to find a new driver update through Windows Update. If that doesn't work, you have to go to the Microsoft Update Catalog and find it yourself.
  • Any Armoury Crate installation (online or full package) should include all latest versions of every driver and library required for the app to work correctly (including net framework, visual or whatever libraries Armoury Crate use). It shouldn't rely on Windows Update to do the rest of the job, since sometimes it doesn't work.
  • In general, this laptop never got Windows 11 official drivers by ASUS. It is mostly using 2019 or 2020 drivers (windows 11 was released in 2021). And I can see that a lot of people here and on Reddit hast this generation, the TUF FX505 and FX507. Maybe a last wave of realtek drivers updates would be very appreciated. Even "Core Isolation Memory Integrity" inside Windows security cannot be activated due to drivers incompatibility (an issue that I'm not interested to report to be honest).

amdryzenmaster.jpg

Screenshot 2024-01-08 163135.png

Yep, that's basically the issue I reported about Silent Mode not working anymore. And that's more or less the way I fixed it, installing old versions of windows and armoury, which I don't consider a real solution because now I'm missing cumulative updates due to the fear of having, again, a loud laptop.

 

Also, I once reported that driver issue via email to ASUS customer support and they make it look like it was my fault and I should reinstall everything again ¬¬. No, it's not my fault, your Armoury Crate installer installs an old version of AMDRyzenMaster. And it's a driver that you can't easily get somewhere else, it's not easy to find the right version in the Microsoft Update Catalog.

 

And also I freaked out once when the laptop didn't boot any longer when a Windows Update activated automatically Memory Integrity inside Core Isolation. It took me a lot of time to realize this was the issue, and to realize that the problem was old drivers. I also wrote to ASUS customer support about it and they blamed my windows installation, suggesting to restore my system ¬¬

You mention this laptop never got drivers for Windows 11. It actually never even got a BIOS update for Windows 11, which is even worse, and it's probably the real reason the laptop doesn't boot when you activate Memory Integrity. They never cared about updating the drivers back in 2021 when the laptop wasn't old, so I already lost any hope now in 2024 that the laptop is 4, almost 5, years old.

 

It's good to know that I'm not the only one having very dumb issues with this laptop, for something so simple like not getting newer drivers (and bios).

Don't forget to send your Google Form, and let's hope they fix the power modes in future Armoury Crate updates.

MasterC
Community Admin
Community Admin

Hi @JayRos and @ChangSinior

An OS update may have triggered this issue. Can you try installing the original config package and see if that resolves it? 

Just unzip and run ConfigInstaller.exe

_____________________________________________________________
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin

Hi @MasterC, thanks for the answer. I wanted to do the full test with the file you shared, and it worked.

  • I did a fresh install of Windows 11 on a tests SSD that I have. Windows 11 23H2.
  • I installed all official drivers and let Windows Update to update everything.
  • I installed the newest Armoury Crate.
  • As expected, the same issue appeared. Silent Mode wasn't limiting my voltage, etc, etc. All that I explained in my previous post.
  • I extracted and run the ConfigInstaller.exe file that you shared in the ACConfig_FX505DT_1.0.0.zip
  • I restarted Windows and now Armoury Crate is working as it should. Silent Mode is silent again.

Screenshot 2024-01-18 164907.png

So, you can share that info with whoever who packs the Armoury Crate updates, that somehow a Windows update is triggering that issue and it's recommended that the next Armoury Crate update execute some sort of "original config package". 

I mean, I've seen other people reporting this issue on reddit, so I guess I'm not the only one.

Thanks!