cancel
Showing results for 
Search instead for 
Did you mean: 

Armoury Crate V5.7.3.0 on TUF laptop / lights and performance modes no longer working

JayRos
Level 9

The version 5.7.3.0 of Armoury Crate was installed this week on my laptop, an ASUS TUF FX505DT, with Windows 11 Pro.

The lights stopped working as soon as I restarted Windows. Going to AC / System / Lightning and applying Reset To Default does not do nothing. No matter what you do, the lights of the keyboard won't turn on again.

So, I decided to do a FRESH INSTALL OF WINDOWS 11. As soon as I end installing Windows, the keyboard lights come to life, with their default Red color. Then I install all the drivers, I install Armoury Crate and... Armoury Crate k1lls the lights again, permanently. 

Maybe I did something wrong, lets FRESH INSTALL WINDOWS 11 once again, with the official drivers from the ASUS Official Website. Everything seems to work, lights are on again. Then I install Armoury Crate and the keyboard lights are gone again, permanently.

 

I also notice that the Performance modes (Silent, Performance and Turbo) are not longer working. Silent used to keep my CPU at 1340Mhz on idle. Now on Silent the CPU is constantly going up and down, between 2300Mhz and 3400Mhz. 

Basically the whole app is gone. The only two reasons I install this app on my laptop are no longer working. Not even after two FRESH INSTALLS OF WINDOWS 11.

 

Screenshot 2023-10-20 185407.pngScreenshot 2023-10-20 185510.png

I know is the new app the one failing because:

  • V5.6.10.0 was working as expected all this time
  • I already fresh install Windows 11 twice and the issue stars only after I install Armoury Crate 5.7.3.0
  • I uninstalled AC and try independent app, GHelper 0.129, and my lights are back! 

I tried to report in the longer Armoury Crate thread but that thread is closed right know. I even made my log file.

2,190 Views
1 ACCEPTED SOLUTION

Accepted Solutions

I found a solution, get rid of Armoury Crate V5.7.3.0 completely. Probably the most broken version of AC they have done in a long time. This is how I did it:

  • Go to Microsoft Store and in setting turn of Automatic Updates, so Armoury Crate won't update in the future.
  • Uninstall AC with the official Armoury Crate Uninstall Tool
  • Uninstall the Asus Control Driver (I prefer uninstall it that just disable it).
  • Download the Armoury Crate Full Installation Package
  • Turn off your WiFi, unplug the ethernet. No more internet till all the steps are complete.
  • Restart the laptop and install AC from the Full Installation Package with the internet off, so an older version of AC will be installed. This will take several minutes, it takes a long to unzip the file.
  • Restart the laptop and the keyboard lights and performance modes should be working again.
  • Turn on your WiFi or connect your ethernet and let windows install / update automatically the Asus Control Driver and the AMDRyzenMaster driver. But don't let the Microsoft Store update Armoury Crate, and if AC ask you to update, just cancel.

My laptop has been working fine like this for the last two weeks.

The fact that they haven't opened a new official thread "Armoury Crate 5.7.3.0 report issues here", and the closed the V5.6.8.0 thread, is a clear indicator that they know this is the worst AC version in months, maybe years.

AC is already too patched. They need to start a whole new AC from zero. Even the GUI of AC 5.X.X.X feels slow. It almost feel like the app was made in java or something.

View solution in original post

3 REPLIES 3

Vipros
Level 7

Same issue for a while now, idk what or how this workaround happens to work for a while but i had logged into a different user account and from that account i disabled the AC driver reenabled the amd driver and then reenabled the ac driver and it would work on the first user account. That is until i restart then it won't work at all freezes on boot up for a while system repair starts and fails and then everything is disabled. But I then back to square one. Sidenote I cannot have my pc plugged into the adapter with amd graphics driver enabled or computer green screens unless i do the workaround mentioned above. So, either I charge the laptop or unplug and enable AMD driver and use PC until its about to power down, disable driver plug in ac adapter and resume charging 

I found a solution, get rid of Armoury Crate V5.7.3.0 completely. Probably the most broken version of AC they have done in a long time. This is how I did it:

  • Go to Microsoft Store and in setting turn of Automatic Updates, so Armoury Crate won't update in the future.
  • Uninstall AC with the official Armoury Crate Uninstall Tool
  • Uninstall the Asus Control Driver (I prefer uninstall it that just disable it).
  • Download the Armoury Crate Full Installation Package
  • Turn off your WiFi, unplug the ethernet. No more internet till all the steps are complete.
  • Restart the laptop and install AC from the Full Installation Package with the internet off, so an older version of AC will be installed. This will take several minutes, it takes a long to unzip the file.
  • Restart the laptop and the keyboard lights and performance modes should be working again.
  • Turn on your WiFi or connect your ethernet and let windows install / update automatically the Asus Control Driver and the AMDRyzenMaster driver. But don't let the Microsoft Store update Armoury Crate, and if AC ask you to update, just cancel.

My laptop has been working fine like this for the last two weeks.

The fact that they haven't opened a new official thread "Armoury Crate 5.7.3.0 report issues here", and the closed the V5.6.8.0 thread, is a clear indicator that they know this is the worst AC version in months, maybe years.

AC is already too patched. They need to start a whole new AC from zero. Even the GUI of AC 5.X.X.X feels slow. It almost feel like the app was made in java or something.

Thank you JayRos,

I followed your instructions to the letter and for a minute it was perfect. I was back at it like before, unfortunately I am unhappy to share that after coming back home from work and powering up the laptop it now will not allow me to boot up and login faster than i can disable the device causing the issues and now my unplugging the laptop to enable driver or plug in to charge laptop with driver disabled work-around is not an option. So i went into recovery environment and tried to do a self diagnostic startup, failed. I went to safe mode and tried to disable or uninstall that way they would reappear (assumingly) as i tried to boot normally becuase same issue. I tried running command line and runinng checks on power config and schemes

Dism.exd and Sfc scans i tried everything until i managed to pull all the data i wanted off my Sdd drive onto an external and inserted a usb of windows 11 and wiped of the 4 drives 2 of them, Leaving only the "system" and "recovery" drives alone. Now some new things maybe you can help me understand or help me understand better but as soon as i started up the fresh install of windows 11 before installing any drivers or updating no issues what so ever let the computer run for about an hour no display issues or green/blue screens but armoury crate did not come preinstalled as it previously was, AMD software will not open and DISM wont work, and when i get to the registry There is no AMD-> CN there nor is it in my App Data-->Local. I wanted to make sure that the version that is in the registry matched the verison that is now installed and i found this (attached). I would send over anylogs or information i can or have obtained to try to rectify this issue 

I would really appericate it and thanks in advanced for anytime you do take to look and also thanks for helping before Screenshot (1).png