cancel
Showing results for 
Search instead for 
Did you mean: 

Armoury Crate v5.2.12.0 / Aura Creator v3.4.3.0 [Report here if any issues]

MasterC
Community Admin
Community Admin
A new major release was just released.
Please install using Armoury Crate Installer v3.2.2.3
https://dlcdnets.asus.com/pub/ASUS/mb/14Utilities/ArmouryCrateInstallTool.zip

Armoury Crate v5.2.12.0 - Core service updates:
1. Armoury Crate Lite Service v5.2.10
2. Armoury Crate Service v5.2.10
3. AURA Service (Lighting Service) v3.05.66
4. ROG Live Service v1.5.10.0

Aura Creator v3.4.3.0 - Core service updates:
1. Armoury Crate Lite Service v5.2.10
2. Armoury Crate Service v5.2.10
3. AURA Service (Lighting Service) v3.05.66
4. ROG Live Service v1.5.10.0

Armoury Crate v5.2.12.0 - New features:
1. Added "Multiple display & slideshow mode" in Aura Wallpaper
2. Added Ukrainian support
3. [Laptop] Added "GameVisual" OSD config
4. [Laptop] Added "Overclocking control" for system configuration
5. [Motherboard] Added "Aura Sync mode" for AniMe Matrix Motherboards
6. Usability enhancements

Aura Creator v3.4.3 - New features:
1. Added Ukrainian support
2. Added AniMe Matrix Motherboard Aura Sync mode support
3. Added Aura Wallpaper multiple displays support
4. Enhanced the UI of available devices list

Armoury Crate v5.2.12.0 - Bug fixes & Enhancements:
1. Wireless device firmware update flow enhancement
2. Improved Aura Ready game lighting effect performance
3. Fixed incorrect device name display issue
4. Fixed Update Center - sometimes cannot process update correctly issue
5. Fixed wireless device battery panel detection and status error
6. Fixed access to device page in Spanish issue
7. Fixed Aura Sync device list doesn't show all connected devices issue
8. Fixed "Service error" issue for specific platform
9. [Mouse] Fixed DPI value cannot save when switching by hotkey
10. [Keyboard] Fixed cannot enter the device page in Turkish and English (UK)
11. [Keyboard] Fixed cannot set key change function in Spanish display
12. UI flow & GUI layout enhancements
13. Other bugs fixes

Aura Creator v3.4.3.0 - Bug fixes & Enhancements:
1. Fixed no effect for some devices when applying Music effect with audio spectrum style and the fifth effect style

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Uninstall Aura Sync software if already installed.
Always uninstall Armoury Crate using our uninstall tool (do not remove manually)
DO NOT delete files manually after uninstalling Armoury Crate
DO NOT modify the registry

Forms MUST be completed and submitted in order to be processed.

Uninstall Tool - v2.1.4
https://dlcdnets.asus.com/pub/ASUS/mb/14Utilities/Armoury_Crate_Uninstall_Tool.zip

Must read before reporting issues:
1. THIS IS NOT A THREAD FOR GENERAL CHAT, please report issues ONLY (try to find related threads or create a new one)
2. Try to reboot the system after updates are installed, and check again.
3. DO NOT report issues if facing improper uninstallation or registry issues - please resolve first
4. Revert system to stock speeds to check if errors are caused by excessive overclocking (even if overclock used to be stable)
5. Verify and confirm issues before reporting (do not make multiple posts while still in the process of troubleshooting)
6. Post a brief description of your issue in this thread (less than 50 words)
7. Record and generate a log (change the extension from .LogE to .txt). Prepare some screenshots and photos if applicable.
8. Complete the online form: https://forms.gle/2fEHtZFG3PzjMfzK7
9. Save the link to the form in case additional files need to be uploaded

Log Collection Tool (must attach to your form) - Instructions
94519
First, check the Record log box to start recording
Agree to the disclaimer
Replicate the issue you are having (reboot if necessary - the log tool will keep running)
Click on the Generate log data button
Save the log file to a location of your choice.
Stop the recording
Remember to upload this log file to the Google Form (change file extension to .txt first)

_______________________________________________________________________________________________________________________________________________

To check if your product is supported in Armoury Crate
https://www.asus.com/us/support/FAQ/1042459
_______________________________________________________________________________________________________________________________________________

Installation Error?
Download and install Armoury Crate Lite Log Tool v1.0.6.0
https://dlcdnets.asus.com/pub/ASUS/mb/14Utilities/Armoury_Crate_Lite_Log_Tool.zip
Refer to instructions
https://www.asus.com/support/FAQ/1041654/
Post a quick description of your issue here, direct message me with the cloud link to the log file.
_____________________________________________________________
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin
39,695 Views
137 REPLIES 137

MasterC@ROG wrote:
After monitoring the handles we concluded that there's no leak:

Testing method:
1. Record the number of handles before enabling the audio mode.
2. Enable the audio mode, observe whether the number of handles fluctuates over time or simply increases
* If it decreases as much as it increases then there's no leak
* The number of handles were about the same before as after an extended period of time (cancelled out)


1. With the "ArmouryCrate.UserSessionHelper.exe" process freshly started, the handles are at 993.
Opening up AC after this, the number of handles jumps to 14674.
Closing and opening the app increases the handles by roughly the same amount ONLY if you close AC and wait at least 5 minutes.
I didn't necessarily observe an irreversible jump in handles if I opened AC immediately after closing it.
The number of handles did not increase after the big jump -- more importantly, the number of handles never reduced (no matter how many times it increased by around 10000 after opening AC).

2. The audio mode in the AniMe Matrix tab only causes a constant increase in handles if "Show Visualizer" is ON.
Turning it off, or closing the AC app, doesn't revert all the additional handles to their original amount, even after waiting for 10 minutes.
It only stops the constant increase.


For #1 & #2, if I restart the AC session helper process, then the handles figure comes down to a more reasonable 1000 or so.

MasterC
Community Admin
Community Admin
Hey Guys,

Please read the instructions and fill in a form, remember to provide a log. It's really simple and does not take much time. Thanks.
Only AndrasROG and TianaV have filled in a form as requested.
_____________________________________________________________
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin

Form received, no log received. Please note that your memory does not support Aura Sync at this time. We will talk to KIngston about having it validated. (See their product page)

Kingston DDR5 Fury 5600 KF556C40BBK2-32 x4 units Armoury Crate don't detected

Item Version
---- -------
Armoury Crate UWP App 5.2.12.0
ROG Live Service 1.5.10.0
Aura Service (Lighting Service) 3.05.66
Armoury Crate lite service 5.2.10
Aura Wallpaper Service Not installed
ASUS AIOFan HAL 1.1.47.0
ASUS AURA Extension Card HAL 1.1.0.18
ASUS AURA Motherboard HAL 1.3.4.0
ASUS Keyboard HAL 1.2.10.0
ASUS Mouse HAL 1.2.0.46
AacDisplay 1.2.27
AacVGA 0.0.5.2
KingstonDram 1.1.12
AURA DRAM Component 1.1.18
ENE RGB HAL 1.1.39.18
ENE_EHD_M2_HAL 1.0.9.12
ENE_QSI_Loki_HAL 1.0.3.0
PHISON HAL 1.0.9.0
Patriot Viper DRAM RGB 1.0.9.4
Patriot Viper M2 SSD RGB 1.1.0.2
Universal Holtek RGB DRAM 1.0.0.3
WD_BLACK AN1500 1.0.14.0

AC Lite Log Tool log received

Hi

2022 M16 laptop here

Still an 502 error even after using the latest uninstall tool linked in this thread.

The error pops up just after having launch the service installation. (The first part goes through).

Any help ?

Please remember to fill in a form.

This version forgets shutdown RGB settings and reverts to the default rainbow setting when I access my ROG STRIX Series AIO settings in Armoury Crate. same goes for the OLED on the motherboard, it reverts to the default setting when I access the AIO settings.

Please fill in a form, see original post for instructions. Thanks.

Jesseinsf wrote:
This version forgets shutdown RGB settings and reverts to the default rainbow setting when I access my ROG STRIX Series AIO settings in Armoury Crate. same goes for the OLED on the motherboard, it reverts to the default setting when I access the AIO settings.
_____________________________________________________________
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin

Please remember to fill in a form.

Jesseinsf wrote:
This version forgets shutdown RGB settings and reverts to the default rainbow setting when I access my ROG STRIX Series AIO settings in Armoury Crate. same goes for the OLED on the motherboard, it reverts to the default setting when I access the AIO settings.
_____________________________________________________________
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin

Resolved in latest version

Aura Service (Lighting Service) 3.05.66 leaks memory & handles at a fairly high rate, especially with lighting set to Rainbow and Aura Performance Mode on. This was present in the previous version. The latest version improved things slightly, as it previously caused a more system-wide performance problem; now it just soaks up memory at an unreasonable rate. It's currently sat on roughly 1GB memory used and 2.3 million handles after 1 to 2 days runtime. I do not have RGB RAM; and only ROG branded devices are connected to the Aura software. Using services.msc to restart LightingService works successfully to release the memory & handles, and start the leaking over again; it's a less than ideal workaround for the problem that avoids the need to reboot to clear it. Memory usage after a reboot or restart of the service is somewhere around 20MB, so the growth to 1GB and beyond is not reasonable behaviour. Form coming up in a moment.


Item Version
---- -------
Armoury Crate UWP App 5.2.12.0
ROG Live Service 1.5.10.0
Aura Service (Lighting Service) 3.05.66
Armoury Crate lite service 5.2.10
Aura Wallpaper Service 1.3.4.0
ASUS AIOFan HAL 1.1.47.0
ASUS AURA Extension Card HAL 1.1.0.18
ASUS AURA Motherboard HAL 1.3.4.0
ASUS Aac_GmAcc HAL 1.0.9.0
ASUS FanCard HAL 1.0.8
ASUS Keyboard HAL 1.2.10.0
ASUS Mouse HAL 1.2.0.46
AacAudioHal 1.3.46.0
AacDisplay 1.2.27
AacVGA 0.0.5.2
KingstonDram 1.1.12
AURA DRAM Component 1.1.18
ENE RGB HAL 1.1.39.18
ENE_EHD_M2_HAL 1.0.9.12
PHISON HAL 1.0.9.0
Patriot Viper DRAM RGB 1.0.9.4
Patriot Viper M2 SSD RGB 1.1.0.2
Universal Holtek RGB DRAM 1.0.0.3
WD_BLACK AN1500 1.0.14.0

94534
Is it supposed to happen ?? Might be why I have error 502 and unusable armory crate since the latest update 😞

Is your system overclocked? Where did you find the ACLS install package? Users are not supposed to install this individually...

See the "Installation Error?" section in the original post, and message me the log directly. Thanks.

roger123 wrote:
94534
Is it supposed to happen ?? Might be why I have error 502 and unusable armory crate since the latest update 😞
_____________________________________________________________
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin