cancel
Showing results for 
Search instead for 
Did you mean: 

Armoury crate v4.2.5.0 [report here if any issues]

MasterC
Community Admin
Community Admin
A new major update is being rolled out. There are several improvement and new features, many of the issues reported have also been fixed.

Suggest to uninstall Aura Sync software if already installed.

Armoury Crate v4.2.5

Core Service Updates:
Armoury Crate Service v4.2.5
Armoury Crate Lite Service v4.2.8
ROG Live Service v1.2.18.0
AURA Service (Lighting service) v3.05.18
AuraLayerManager(AURA lighting effect add-on) V0.0.18

New Features
Added AniMe Matrix Editor multi-device support
Added FanXpert feature for Motherboard device type
Added "ROG CITATEL XV" direct link to "Recommended"
Compatibility for Windows 11

Bug Fixes & Enhancements:
Fixed system suspend/resume lighting effect frozen issue
Fixed Dashboard CPU usage bug
Fixed low frequency service crash issue
Fieed G-Skill DRAM Aura Sync issue
Fixed Bluetooth headset connection bug
Optimized component update process & Fix update failed issues
Enhanced GUI layout and UI interactive behavior

Newly Supported Models:
[Mouse] TUF GAMING MOUSE X KIMETSU NO YAIBA
[Headset] TUF GAMING H1 WIRELESS
[Webcam] ROG EYE S

--------------------------------------------------------------------------------------------------------------------------
To update to the latest version of Armoury Crate, reboot and the update will run in the background automatically (do not open Armoury Crate for 10-15 minutes, and plug in the power for notebooks).

Before reporting issues, please make sure you have the latest software and firmware.
Be clear about the key issue. Mark/edit posts which are no longer relevant, tracking multiple posts in several pages not only takes time but the issue becomes unclear.

When reporting a new issue, include the following info:
1. Clear description of your issue
2. PC / Laptop
3. Aura Sync products
4. 3rd-party peripheral, audio, or lighting software
5. Wired / wireless connection
6. Reinstalled Windows?
7. Windows version & build
8. Previous version of firmware or software that worked as expected
9. Any screenshots of the issue
10. Use our log collection function: Settings=>About=>App diagnostics
Please provide a log, it's much easier to provide fixes if we can replicate as accurately as possible.

NEW - When your issue has already been reported
To make reporting easier for you, if you see another member post the same issue you are experiencing:
1. Simply reply and add your name at the bottom of the post. (If someone else has already replied, then reply to that post and add your name to the list)
2. Record and generate a log.
3. Private message me and include the following:
a. The post link at the top right of your post (copy and paste the link)
89824
b. Link to your log file stored in cloud, and screenshots if any.
c. Service version info
89825

--------------------------------------------------------------------------------------------------------------------------
Log Collection Tool - Instructions
First, check the Record log box to start recording
Agree to the disclaimer
Replicate the issue you are having
Click on the Generate log data button
Save the log file to a location of your choice.
Stop the recording

Even though the log file is encrypted, share the log file with me by PM (provide link to file in cloud).

Many issues have been posted previously, but a very small percentage of people have PM'd me their log. If in doubt, just send a log and remember to record first. If the issue is after shutdown: provide a log for before shutdown and one after (2 logs). Thanks everyone!
_____________________________________________________________
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin
561 Views
309 REPLIES 309

Good news! MainSDK v1.02.25 (Device Kit – ASUS Core SDK) was released today to resolve the ArmourySWAgent pop-up issue.

MasterC@ROG wrote:
Hey Guys,
The root cause for the ArmourySWAgent issue has been found, it should be resolved by the end of the month.
_____________________________________________________________
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin

Below my details.
I can't access to settings pages of my Falchion or Strix Impact 2 wireless.
Tried uninstall and reinstall with or without the uninstall tool. Nothing worked. My pc Ryzen 2700x
I tried this with my old X99 build that one only mouse settings worked not the keyboard.
And tried with my work pc which has an 11700k both keyboard and mouse settings working so weird problems.
Now I need to take my mouse and keyboard to work to change settings which is so sad :(((
Please help...

Update: Now my work pc cannot edit settings of Falchion with the new update ... Infinity loading screen 😞

1. The device page isn't loading within 0.3 seconds
2. PC, custom build
3. Aura Sync products - Falchion , Strix impact 2 wireless
4. 3rd-party peripheral, audio, or lighting software - Creative Sound Blaster G6
5. Wired / wireless connection - wireless for both keyboard and mouse
6. Reinstalled Windows? Yes
7. Windows version & build - 21H1 / 19043.1237
8. Previous version of firmware or software that worked as expected - 4.1.6.0
9. Any screenshots of the issue - will PM
10. Use our log collection function: Settings=>About=>App diagnostics

Item Version
---- -------
Armoury Crate UWP App 4.2.5.0
ROG Live Service 1.2.18.0
AURA Service (Lighting Service) 3.05.18
Armoury Crate lite service 4.2.10
ASUS AIOFan HAL 1.1.35
ASUS AURA Extension Card HAL 1.1.0.11
ASUS AURA Motherboard HAL 1.1.7.0
ASUS Keyboard HAL 1.01.48
ASUS Mouse HAL 1.2.0.11
AacVGA 0.0.4.3
KingstonDram 1.1.8
AURA DRAM Component 1.1.14
ENE RGB HAL 1.1.37.0
ENE_DRAM_RGB_AIO 1.0.0.10
ENE_EHD_M2_HAL 1.0.9.1
PHISON HAL 1.0.9.0
Patriot Viper DRAM RGB 1.0.9.2
Patriot Viper M2 SSD RGB 1.0.6.4
Universal Holtek RGB DRAM 1.0.0.2
WD_BLACK AN1500 1.0.13.0

ive updated to the new 4.2.5.0 and now my overdrive button is missing .... ive also had my display button missing for quite some time now ... can we get this sorted ASAP ?

MasterC
Community Admin
Community Admin
Hello to new members, welcome. To respect those who have posted before you, do not spam the thread until you get a response. There is a queue, and so you may need to wait (unless only a quick response is required). This is a discussion forum, not an instant helpline (contact ASUS Customer Support in your region). And this thread is dedicated to issues specific to Armoury Crate, if anyone has suggestions - please find related threads or start a new one. I'm here to help so stay positive, If anyone persists to make this a complaint thread - he/she will be removed from the forum permanently. Dealing with such posts will result in less people being helped.

* Remember to provide sufficient info - read the first posts of this thread, there are examples.
* Avoid posting and reposting while you troubleshoot, this results in multiple posts and I may not be clear which ones are still relevant. You can update previous posts to consolidate, delete if necessary so we're not trying to replicate an issue when you have already resolved it.
* Please indicate if you know how to fix an issue or we have resolved it, some of you have done that to help others - much appreciated!

Thanks!
_____________________________________________________________
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin

MasterC
Community Admin
Community Admin
I noticed some people asking about the disappearance of the OverDrive button. The latest version of Armoury Crate requires you to update the driver for OverDrive as well.
First you'll need to uninstall the existing version (Settings>Apps>RefreshRateService). Some people reported that the pop-up is in Chinese (I have informed the team), just select the following.
90105
Download, unzip, and install the latest version of RefreshRateService:
Download link:
https://dlcdnets.asus.com/pub/ASUS/GamingNB/AppforWin10/RefreshRateService/RefreshRateService_V2.1.0...
90106
_____________________________________________________________
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin

MasterC@ROG wrote:
I noticed some people asking about the disappearance of the OverDrive button. The latest version of Armoury Crate requires you to update the driver for OverDrive as well.
First you'll need to uninstall the existing version (Settings>Apps>RefreshRateService). Some people reported that the pop-up is in Chinese (I have informed the team), just select the following.
90105
Download, unzip, and install the latest version of RefreshRateService:
Download link:
https://dlcdnets.asus.com/pub/ASUS/GamingNB/AppforWin10/RefreshRateService/RefreshRateService_V2.1.0...
90106


Hi MasterC@ROG, it is possible for ASUS to push out an update for these services automatically like the RefreshRateService when app such as Armoury Crate require the latest version of it.

As it is not really user friendly for people to keep checking the service version and to reinstalling it all the time. By asking us to manually install the new version, it would also risk the customer (us) doing mistakes in the procedure, risking our whole machine to maybe malfunctioning in some way.

This is just a comment. In my opinion, it is might be better to make the Armoury Crate compatible with all versions of RefreshRateService as I hardly see any performance difference with the different version of this service but I might be wrong as there might be some reason behind I don't know of.

I'm with you on that, and I have reflected this to the team. It's not clear for users to know what to do.

JonTeoh wrote:
Hi MasterC@ROG, it is possible for ASUS to push out an update for these services automatically like the RefreshRateService when app such as Armoury Crate require the latest version of it.

As it is not really user friendly for people to keep checking the service version and to reinstalling it all the time. By asking us to manually install the new version, it would also risk the customer (us) doing mistakes in the procedure, risking our whole machine to maybe malfunctioning in some way.

This is just a comment. In my opinion, it is might be better to make the Armoury Crate compatible with all versions of RefreshRateService as I hardly see any performance difference with the different version of this service but I might be wrong as there might be some reason behind I don't know of.
_____________________________________________________________
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin

MasterC@ROG wrote:
I'm with you on that, and I have reflected this to the team. It's not clear for users to know what to do.


MasterC@ROG,

So...Can I assume that an automatic update of ArmouryCrate/RefreshRateService will be pushed out by ASUS to fix this on a later date? Instead of manually uninstalling and reinstalling the RefreshRateService.

MasterC@ROG wrote:
I'm with you on that, and I have reflected this to the team. It's not clear for users to know what to do.


MasterC@ROG,

So...Can I assume that an automatic update of ArmouryCrate/RefreshRateService will be pushed out by ASUS to fix this on a later date? Instead of manually uninstalling and reinstalling the RefreshRateService.

sdmf74
Level 11
Well I have been without Armory Crate for well over month because of its issues. I thought some fixes were supposed to be released by the end of september?

Im also getting the following Access violation in AISUITEIII. There are a few bugs in AISUITEIII and it has NOT been updated since MAY!
90120
ASUS Maximus 13 Hero, Intel I9 11900k, EVGA GeForce RTX 3080 FTW3 ULTRA