Showing results for 
Search instead for 
Did you mean: 

Armoury Crate Update V5.7.3.0 issues

Level 8

I installed the new update yesterday and since then the APP doesn't recognize my RAM. I managed to restored to the default visual effect but the Armoury Crate still found this device in the AURA sync tab.

Another thing I noticed is that my motherboard Rog strix z370-F gaming isn't in the devices tab anymore. And it has always been there to set up the individual lightings and RBG calibration, etc..

Another issue I found is that in the aura sync tab there is a new device called ARGB header that doesn't do anything. I can turn it On or Off but can't see the difference. 

Has anyone had a similar problem?
It was working well until the last update from Armoury Crate and some other updates in the "Update Center".
Already tried:

  • Uninstalling and installing Armoury Crate
  • Went to BIOS and turned off "RGB LED lighting" and ErP Ready to "Enable(S4+S5)" and turned back on the RGB LED.

Note: I have an IAO Pump with RGB and that is connected to rgb_header2 in the motherboard. RGB_header1 is not connected to anything.


Level 8

I'm having issues too! My Strix 4090 no longer shows up in the Aura sync tab and I can no longer control it at all! Also the Asus plugins for ICUE do not work so I can't control my RGB that way now either. I've tried using the uninstall tool and reinstalling 5x now, the problem comes back as soon as my pc reboots, my GPU is gone. I also cant adjust the Anime Matrix shut down or start up affect, when i go to apply my previous one Armoury Crate just gets confused and crashes!

Level 10

These ASUS or whoever is responsible, EVERYTHING HAPPENS, THEY NEITHER READ THIS WEBSITE OR FIND OUT, nor do they try to find out, since the first day they applied this update I put the same thing THAT DIDN'T DETECT MY KINGSTON PREDATOR RGB RAM installed , the previous version of worked as expected, and from what I see I AM NOT THE ONLY ONE WHO HAS PROBLEMS WITH THE UPDATE on any device installed on your PC or LAPTOP. THERE IS A VERY OLD SAID THAT SAYS "WHAT WORKS, DON'T TOUCH IT"

Yep. The previous version was working as expected. Not perfect, but never has been perfect. is the worst in a long time. my keyboard lights on my laptop don't turn on. the Silent/Performance/Turbo options no longer work. 

And somehow I don't think this will be fixed soon.

Level 7

Having same issues as you.  I updated last night and the issue I encountered is my GPU lights doesn't sync and with the rest of the devices and runs on its default light settings whenever you reboot (even after syncing it prior). I had to open up Armoury crate to uncheck then re check the GPU in the sync devices tab for it to work again with Aura Sync. Tried to reinstall Armoury crate couple of times to see if it resolves the problem, but same issue remains. 

From what I noticed, the update seems to have caused an Aura sync issue wherein the GPU reverts back to its default light settings every time the PC is rebooted, even if it is set to align with Aura sync before you reboot. My RAM and the MOBO lighting are working fine so far with Aura sync. Only the GPU lighting is the one affected.

It's quite annoying that they always have this issue. It happened to me before with the RAM lighting. The previous version works fine, so I wonder what they did this time around to mess things up.


Let me know if you ever managed to resolve it. I hope they send a new update to fix the problem, as the recent one clearly has some issues.


Level 8

Sorry guys been away and didn't check the reply.

Thank you for your contribution, I'm still trying to find solutions for the problem.
It's still the same as before.

I hope we get ASUS ROG attention's to this forum so they can help us out.

Level 8

Hey dude, use the Armoury Crate uninstall tool, then restart, and then install the Asus full package, from here you can select what you want to install and it installs an older version of armoury crate that doesn't auto update as its installing, this has solved the issue for me at the moment! Once i had updated it I went into Microsoft store and disabled auto update for apps, this blocked it from trying to install the update when it tried to update after restarting the app and so far as not been able to update itself, I also disabled windows updates for now just in case. Everything seems to be working for me at the moment, It's still hit and miss whether my 4090 Strix will show back up in Armoury Crate though, but it seems to have kept its sync settings for now at least. Sometimes it will show sometimes it will not, not sure if new Nvidia drivers have had something to do with that, still trying to figure out if its that or Armoury crate.

From what i hear they don't check here or reddit. I have my fingers crossed though!!

Level 8

Hey thank you for replying ! 
I just tried your process and it didn't work for me. I still can't manage my MB or my RAM. And i still have a ARGB HEADER that doesn't exist .

I send you the picture of what i see in armoury crate:

Screenshot 2023-11-01 162422.png

Level 7

Same Problem bro, even my AIO Cooler RGB didn't Sync the RGB Light to Motherboard and also in the Armoury Crate didn't Connected.

Level 8

Hi, just a few quickies about the update.

Do you collect WER reports? Clicked to dashboard and crashed with exception 80004003.

For the Asus TUF B450-PLUS GAMING all S/W is up-to-date

In the explorer folders there are DLLs in Program Files folders

  • ENE (2021)
    PHISON (2021)
    PD (2023)
    Patriot (2023)
    ASUS (2023)

In Program Files (x86) there's one ASUS folder with 11 folders, including one which looks like the main installation folder.

Could these installed components ever be selectively added/removed in AC? It would also be cool to see above corresponding folder locations for all the Devices & Components entries in the Settings :Updates section.

Also, unable to go any further on the Device icon on the left, because keeps offering option "You must first update your device to continue." It's definitely up to date.

Thanks. 😀

It's on at the vault