cancel
Showing results for 
Search instead for 
Did you mean: 

Armoury Crate - Tools menu gives "Unknown error with content. Please try to restart Armoury Crate."

decimus28
Level 10

I would like to be able to access the Tools menu in Armoury Crate but I get the following every time.

"Unknown error with content. Please try to restart Armoury Crate."

 

Every onther menu works fine. Restarting the software, reinstalling the software and restarting Windows does not fix the issue. I don't want to do a Windows reinstall as I have 2200 games installed so that is not an option for me right now. Is there a way to fix this?

3,490 Views
12 REPLIES 12

tangleswog
Level 8

I have the same issue across 2 different ASUS motherboards.

srmd22
Level 8

I have this same darn issue.

Lutepatious
Level 7

I have the same issue on ROG STRIX Z790-F Gaming Wifi.

Lutepatious
Level 7

I found this error caused at "Visual Studio" installed PC.

Some component in Visual Studio 2017, Visual Studio 2019, Visual Studio 2022 conflicts Armoury Crate tools menu.

srmd22
Level 8

After several months of fooling with Armoury Crate, with a fresh install of Win 10 on a pretty much all-new parts PC (except some legacy hard drives and accessories), I have come to the conclusion that it is just a broken, dysfunctional piece of crap. I took it out of the start up folder (which you uncheck the start up settings list now in W10, who knows where the actual folder is anymore) awhile back, and now I am just gonna uninstall it, because I don't see any real need for it - it is bloatware.

GODFACE
Level 8

the team over at asus is really not wanting to be around much longer.  I hope they know the petition isn't looking good for them.  The lack of response should go to show you all that you should stop giving money to this company

Bunbun08
Level 7

I somehow fixed the issue by going to settings changed my theme to tuf gaming , went to the update center and checked for updates found 3 components ready for update  gamesdk asus hal center and forgot the 3rd one after the update i closed the app then reopened it went to tools and as it was loading i went to individual kits aand somehow everything loaded now

I can't believe it but it worked for me too. fir a minute. Just tried opening the tool again (after it worked for me once) and guess what, the same error. Oh well I was hopeful.

2023-07-04_22-01-10.png

Just an update, if you get the error, change the theme and update everything you need to. Then the same error will occur next time. When this happens....you guessed it....change the theme and update the drivers you need to. I think it it a rinse and repeat situation...