cancel
Showing results for 
Search instead for 
Did you mean: 

Armoury Crate - Tools and drivers installation - Stops on 55%

Nantonl
Level 7
The application works well, but when i try to download tools or updates, it stops at 55%.
I searched many times for a solution in everywhere, but nothing works.

Could anyone help me please?

I tried:
- Another versions.
- Reinstall (using the uninstall tool).

Motheboard: ROG STRIX B550-F (WI-FI)
Armoury crate version: 4.0.8.0
13,413 Views
7 REPLIES 7

malley_vinom
Level 7
Got the same issue and tried the same things here, I get a message saying that Windows cannot find AsusSetup.exe.

Anyone got any ideas how to fix this?

When I tried to install it, I just left it installing for about 10 minutes. After some time stopped, the installation continued until finish.

tomrpowers
Level 7
Thanks MiniRawr - I went to grab a cup of coffee and when I came back, sure enough it finished installing!

There's a workaround:
https://youtu.be/eEMbnlSeA-8

LeMonapart
Level 7

I had same issue. To fix that I just uninstall all armoury programs then I installed armoury crate again with administrator permission. To do that you need to right click on install file then select run as administrator option 

Extremely useful when your motherboard / computer does need driver updates. If you have been experiencing problems with Armory Crate itself it could be because you have Apps > Advanced app settings set to "Microsoft Store Only" and by doing this Armory Crate will be denied to ability to download the LAN driver, Wifi Driver, Bluetooth drivers in the armory crate app itself. It will show and stay stuck at 55%

That being said all you have to do is go to Apps > Advanced app settings and switch it to " Anywhere but warn me when getting apps not directly from microsoft" (edited)


Re-open Armory Crate and attempt to download the driver again and it will 100% comeplete then restart PC. BOOM simple fix to everybodys 55% problem with Armory Crate. (edited)
[12:53 PM]
I literally just went from firewalls to everything. This is a common problem many people even posted on reddit. Simply fixed. Now I must go teach more.

Dizztroyer
Level 7

Hi Guys

My armoury crate audio is not working. What do you think is the issue?