Showing results for 
Search instead for 
Did you mean: 

Armoury Crate SE Crashing on Launch - Can't Manage/Control my Ally

Level 7

Upon trying to open Armoury Crate, it crashes immediately without showing anything except a blank window.

I have tried:

1.)  Uninstalling using the official uninstaller and reinstalled.
2.)  Uninstalling using the official uninstaller, removed all ASUS registry keys, removed all ASUS appdata info, and reinstalled
3.)  Did a repair install of Windows 11, keeping my applications and settings
4.)  Ran System File Checker
5.)  Created a new local administrator account on a fresh Windows profile and tested

This is making my Ally basically useless.  I can't control the fan profile, I can't adjust the iGPU VRAM, I can't use the launcher, I can't check for updates, I can't customize control center.  What I am supposed to do?  Reinstall Windows every time Armoury Crate has a problem?

Nothing works, and I get the exact same errors in Event Viewer no matter what I try:

Faulting application name: ArmouryCrateSE.exe, version:, time stamp: 0x647d88bb
Faulting module name: Windows.UI.Xaml.dll, version: 10.0.22621.1778, time stamp: 0x2b8b6f52
Exception code: 0xc000027b
Fault offset: 0x0000000000869bb0
Faulting process id: 0x0x39B0
Faulting application start time: 0x0x1D9A7DC675BCAA4
Faulting application path: C:\Program Files\WindowsApps\B9ECED6F.ArmouryCrateSE_1.2.10.0_x64__qmba6cd70vzyy\ArmouryCrateSE.exe
Faulting module path: C:\Windows\System32\Windows.UI.Xaml.dll
Report Id: f89d82a1-0edb-4303-8c01-8eb970f55ce1
Faulting package full name: B9ECED6F.ArmouryCrateSE_1.2.10.0_x64__qmba6cd70vzyy
Faulting package-relative application ID: App


Fault bucket 2255532234018978785, type 5
Event Name: MoAppCrash
Response: Not available
Cab Id: 0

Problem signature:
P1: B9ECED6F.ArmouryCrateSE_1.2.10.0_x64__qmba6cd70vzyy
P2: praid:App
P4: 647d88bb
P5: combase.dll
P6: 10.0.22621.1485
P7: a8be94cc
P8: 80004003
P9: 000000000009200b

Attached files:

These files may be available here:

Analysis symbol:
Rechecking for solution: 0
Report Id: f89d82a1-0edb-4303-8c01-8eb970f55ce1
Report Status: 268435456
Hashed bucket: ab311e1fbdc08627bf4d429dd424fbe1
Cab Guid: 0


Level 7

I have same issue on B9ECED6F.ArmouryCrate_5.6.8.0_x64__qmba6cd70vzyy, and no reply from rog?

Level 7

Almost same error here, just the faulty module is KERNELBASE.dll for me. App works exactly ONCE after fresh install