Showing results for 
Search instead for 
Did you mean: 

Armoury Crate "Redirecting" and "Login Failed. Please sign into

Level 7

I've seen a few posts already and they've pretty much gone unanswered, and it's frustrating, so I'll start a new one in case i'm not the only one having this issues.

For the past 6+ weeks, i have not been able to sign into the User Center of Armoury Crate. I get an error that says "Login Failed. Log into one of the apps below first, and then try logging into Armoury Crate again" The list below is empty, so I'm not sure what Armoury Crate wants me to log into...

i've reinstalled Armoury Crate about 10 times today, it's getting frustrating.

I have followed instructions i've seen on this forum and reddit, and nothing worked: i.e. go into Apps -> Click on Armoury Crate -> Advanced Options -> tried both Repair and Reset; nothing.

I've reset Windows and reinstalled it, nothing.

Checked my firewall properties and disabled the rules for both MyAsus and Armoury Crate, nothing canges

I'm at a loss, it worked fine not long ago as I've been running Aura Wallpaper; now i can't even access the Content Platform to download the wallpaper again as it's asking me to log-in. 

I'm on a call with Asus right now and they have told me that the Armoury Crate support team have not heard of this issue, yet i've seen posts for Months, even years of this issue happening, with no actual fix, and asked me to provide them with a feedback form so they can look into this further.

Has anyone figured out a fix for this?

My system:

Intel i9-12900k
Asus ROG Strix Z690-E
Corsair Vengeance 64gb DDR5
Asus ROG Strix RTX 4070Ti OC
WIndows 11 (up to date)

Screenshot 2023-05-24 183138.jpgScreenshot 2023-05-24 183207.jpg


Level 7

Same thing after last armory crate update.

Level 7

have exactly the same problem with my b550f gaming wifi. armoury crate problem and cmos battery always  run out after a month..

Level 7

I have the same problem



Same here. So annoying. If Armory Crate has it on ROG Ally, makes me wonder if those complaints are legit. 

i9-13900K, Windows 11 Pro, Z790-a Gaming Wifi, Strix 4080 OC White

Level 7

the same problem, guess I'm gonna look for some other Asus app to login first.

There's no other Asus app to log in. Lol. I'm surprise that Asus created a forum yet there's no moderator. 

Level 7

I just ran into this. Here's how I got around it.

  1. Open Armory Crate
  2. Click on the User Center button (2nd from the bottom with an outline of a person)
  3. Instead of clicking on your account on the right side of the screen, click "Sign in with another account"
  4. Enter your credentials (feel free to click "remember me") and click the "sign in" button
  5. After loading for a sec, you should be signed into Armory Crate again

Thanks. It works. I didn't find Sing in with another account. Instead, I click add another account and used the original credentials. But I guess it's the same workaround.

Thanks again.

This worked for me.